Résolu

Permettre le Content Server de Calibre Library sur Mon Mac d'être joignable de l'internet


Badge
Bonjour, je possède un MacBook et sur celui ci j'ai un ensemble de livres pdf que j'utilise avec le logiciel Calibre Library.

Calibre permet de générer un serveur de contenu qui devrait être accessible de l'internet aussi.

Mais voilà, je n'arrive pas à configurer mon routeur Voo pour y accéder de l'internet.

Calibre spécifie qu'il faut forwarder sur le router le port 8080 (enable port forwarding on the router to forward the port
code:
8080).


code:
Je n'ai aucune option pour faire ca sur mon routeur car elle n'apparait pas et c'est déjà bizarre ca. Voici ce que j'ai après l'option NAT, directement l'option DMZ et pas l'option pour forwarder.


code:
Comment puis je accéder ce serveur de contenu depuis l'internet?


code:
Merci d'avance.


icon

Meilleure réponse par DDA 12 janvier 2019, 10:23

Si vous voulez connecter depuis l'extérieur, vous devez utiliser l'IP WAN et non votre IP locale.
Le NAT permet de rediriger le trafic depuis l'extérieur vers votre IP locale 😉
VOO ne change pratiquement jamais d'IP, sauf sous certaines conditions, comme par exemple le changement de modem.

Il est possible que ce système fasse du DNS via leur services (vous avez alors du faire un compte chez eux) et alors ce sera le nom de votre compte qu'il faudrait utiliser, l'avantage serait que même si vous changeriez d'IP WAN, il fonctionnerait toujours..

Edit :
IP WAN:9090 évidemment

Afficher l'original

29 commentaires

Badge
Merci encore à vous deux. Oui, je viens de l'indiquer. Bon week-end.
Nickel, ce n'est pas difficile dès que toutes les conditions sont réunies 😋
Si tout est OK, pouvez-vous indiquer quel post vous a aidé pour les autres clients dans le même cas 😉
Badge
YES! ca marche semble t il 😉 ouf enfin. Je vais tester encore cela. Merci.
Badge
Ah bon. ET si je comprend bien, je dois utiliser l'adresse IPv4 que je trouve dans l'option WAN sous Réseau ? c'est ca? et ca va router sur l'adresse du Mac sur lequel Calibre tourne avec ce port ou ?
Si vous voulez connecter depuis l'extérieur, vous devez utiliser l'IP WAN et non votre IP locale.
Le NAT permet de rediriger le trafic depuis l'extérieur vers votre IP locale 😉
VOO ne change pratiquement jamais d'IP, sauf sous certaines conditions, comme par exemple le changement de modem.

Il est possible que ce système fasse du DNS via leur services (vous avez alors du faire un compte chez eux) et alors ce sera le nom de votre compte qu'il faudrait utiliser, l'avantage serait que même si vous changeriez d'IP WAN, il fonctionnerait toujours..

Edit :
IP WAN:9090 évidemment
Badge
Bon, je fais exactement comme vous dites. J'ai calibre avec l'adresse 192.168.0.11:9090

et dans le NAT je met:



ET donc par exemple sur mon mobile en wifi local, ca marche mais si je teste en désactivant le wifi pour qu'il se mette en data et donc en mode internet vers calibre alors rien ne marche plus. Dites moi si vous avez l'écran d'accueil utilisateur/mot de passe quand vous essayez avec cette adresse? Je ne comprends pas se qui bloque, ca semblait pourtant simple...
Heuuuu, je ne comprenais pas ce que vous vouliez dire.
Je suis donc retourné dans le tuto ... en effet ce menu y est visible, mais rassurez-vous, je ne l'ai pas non plus 😆... sans doute avec une version plus ancienne du Technicolor
Ne tenez pas compte de ce menu, c'est via NAT que vous devez travailler 😋



Voici un exemple pour le port 80, remplacez par 9090 ... et Both pour le protocole (ne sachant pas si c'est du TCP ou UDP, en mettant Both, les 2 fonctionneront).
Le tuto dit de laisser les ports début et fin externe par défaut, en y mettant le port cela fonctionne également, je ne sais donc pas avec certitude si c'est à faire ou pas 😉
En tout cas, moi je fais comme dans mon exemple et cela fonctionne !

Edit:
Renseignez-vous bien sur le port à utiliser, nous sommes avec le 8080 et 9090 ... tant que le bon port ne sera pas ouvert, cela ne fonctionnera probablement pas 😙
Badge
Je n'arrive pas a voir l'option "redirection de port" sous le menu NAT à gauche. Pouvez vous me dire ce que je peux faire pour enfin voir cette option? c'est dingue ca quand même, j'ai l'impression d'être le seul à pas voir cette option 😢
PierreZen a écrit:

Sur mon Macbook, le serveur de contenu calibre une fois activé me donne une adresse ip avec port comme 192.168.0.11:9090 J'essaie avec cet autre port mais ca ne donne rien de neuf.


Si cette adresse qu'il tente de connecter par défaut, dans votre NAT, mettre 9090 au lieu de 90.
Remarque importante, l'adresse IP externe doit rester à 0.0.0.0 !!!
Cela est indiqué dans le Tuto que @roylion15 avec mit en lien : laisser par défaut
Badge
Bon... je n'arrive a rien ... impossible d'accéder de l'internet alors que dans le réseau local de la maison ca marche.

Sur mon Macbook, le serveur de contenu calibre une fois activé me donne une adresse ip avec port comme 192.168.0.11:9090 J'essaie avec cet autre port mais ca ne donne rien de neuf.

J'ai juste mis cette règle dans le NAT comme mon Airport est en mode bridge derrière le Voo Technicolor routeur et que je n'ai pas de firewall activé pour l'instant :



Question subsidiaire, comment se fait il que je ne vois pas le menu "redirection de port" à gauche en dessous du menu NAT ? Impossible de la voir !

Badge
merci à vous deux déjà pour toutes ce informations. Je pense que c'est l'agencement de celles ci avec les bons paramètres de mes adresses mac et IP qui pourront solutionner mon problème en effet.

Je ne dois pas encore avoir réussi à mettre la bonne séquence d'adresses et je vais ré-essayer encore jusqu'à obtenir ce que je souhaite (que cela fonctionne). ;-)

Je vous tiens au courant. Merci.
Niveau d'utilisateur 7
Badge +12
Suivez ce tutoriel pour savoir comment créer une règle correcte : https://forum.voo.be/ma-connexion-internet-17/tuto-comment-ouvrir-des-ports-sur-le-modem-technicolor-2800
roylion15 a écrit:

De toute façon la règle nat est fausse ça ne marchera jamais...
vous devez rediriger vers l’ip locale du serveur


En plus 😉
Niveau d'utilisateur 7
Badge +12
De toute façon la règle nat est fausse ça ne marchera jamais...
vous devez rediriger vers l’ip locale du serveur
PierreZen a écrit:

Voici le Nat du routeur Voo:

J'ai mis l'adresse IPv4 du routeur ... est ce bon ?


Vous voulez dire du aiport ?
Vous ne parliez pas du port 8080 ? ... utiliser le port 80 qui est le port standard HTTP n'est pas une bonne idée

le logiciel "Calibre Library." ne peut pas être configuré sur un autre port, ex. 81 ou 8080... ?



  • Introduire la MAC de votre airpot
  • Introduire l'IP souhaitée ... devra être la même pour le NAT
  • Activé en bas à droite
Chaque réservation aura une ligne.
Ne regardez pas mes IP, elles ne sont pas standard chez VOO ... résidus de PXS, avant de venir chez VOO ... pas eu envie de reconfigurer mes appareils de l'époque 😚
Badge
Voici le Nat du routeur Voo:

J'ai mis l'adresse IPv4 du routeur ... est ce bon ?

Badge
Non. Je fais ca comment?
Niveau d'utilisateur 7
Badge +12
Faites un screen de votre règle de nat du modem routeur Voo ... c’est pas la peine de masquer vos IP locales sinon on ne comprendra rien 😀
le port en question « 8080 » est un port à ne pas utiliser pour votre serveur car peut être utilisé par le modem Voo pour un accès distant ...
Et aussi est il effectivement ouvert dans le pare feu de Mac OS ?
Avez-vous fait une réservation d'IP avec l'adresse MAC de l'airport ? ... histoire de fixer son IP et que le NAT puisse toujours fonctionner.
Il devra être dans le range du DHCP et sur une adresse libre
Badge
L'airport est en bridge

Niveau d'utilisateur 7
Badge +12
Vous faites du double nat ? Ou l’airport est en bridge ?
Badge
J'ai une adresse IPv4 sur le routeur 95.XX.XX.XX

le routeur est ensuite connecté à un Airport Express et quand je regarde l'adresse IP d mon MacBook su rte quel le serveur de contenu Calibre , l'adresse IP est 198.xx.xx.xx

Je configure en NAT sur le routeur Voo l'adresse 198.xx.xx.xx avec le port 80 80 mais rien ne fonctionne
Votre NAT est-il configuré ?
Cela fonctionne-t-il ?
Badge
Oui c'est OK, en WAN j'ai une adresse IPv4 95.xx.xx.xx
j'ai aussi de l'IPv6

Commenter

    Gestion des cookies

    Nous utilisons des cookies pour améliorer et personnaliser votre expérience. Si vous acceptez ou continuez de naviguer, vous acceptez règles relatives aux cookies. En savoir plus sur nos cookies

    Accepter les cookies Paramètres de cookies