Connexion à distance à ma domotique impossible avec IP publique via dyndns


Badge +1
Bonjour,

Je fait appel à ce forum et sa communauté pour résoudre mon problème.
J'ai une installation domotique Domintell que je souhaite contrôler à distance. Pour cela, j'ai installé l'app sur mon portable et configuré leur module DETH02 (adresse IP 192.xxx et ouverture du port 17481).
Côté Voo, j'ai une adresse IP publique 217.xxx et les services dyndns du modem sont configurés. Le modem est en mode router.
Côté dyndns, je pointe bien vers l'adresse IP publique et tout est en ordre.
Côté app, l'adresse est celle de mon dyndns, l'IP locale est celle du DETH02 (192.xxx), le port est bien le 17481.
Lorsque je ping vers le DETH02 de mon pc portable, il répond bien donc il est bien reconnu dans mon réseau local.
Malgré cela, je n'arrive pas à me connecter à ma domotique aussi bien via mon wifi interne que via la 4G à distance…. cela fait plusieurs jours que je tourne en rond.
Est ce que quelqu'un pourrait m'aiguiller?
Merci
Vh57001

73 commentaires

Badge +1
Encore un grand merci.

Bonne soirée.
Youpieeeee ... 😌

Comme je l'avais dit il y a quelques posts, j'étais persuadé que cela fonctionnait avec le Technicolor.
La nuit a permise de ce changer les idées, le reset factory a peut-être aidé également.

Cela n'empêche que son comportement en DHCP n'est pas normal ... le passage par le service technique serait à faire, 9 chances sur 10 qu'il doit y avoir un nouveau firmware qui résout des bugs 😉
Badge +1
MIRACLE……
J'ai remis mon module en IP fixe sur le 100.
L'adresse MAC du module est réservée à la 100 dans le LAN
Configuré le NAT sur le 100 et le port 17481.
Sur mon appli, cela marche en WIFI local et par la 4G......
Vous n'êtes pas du genre curieux apparemment et tenter l'IP fixe ... 😂🤣
Badge +1
Merci en tout cas.
J'ai déjà été chez le fabricant par le passé qui m'avait dépanné. Je pense que je vais devoir y retourner...
La fixe est ok mais pas celle qui doit clignoter.
Hier en ip fixe, elle clignotait correctement et mon appli fonctionnait.
Je vais voir avec le fournisseur du module.

Vous pouvez toujours tenter le coup en IP fixe (IP libre évidemment) en attendant la réponse de votre fournisseur.
IP fixe dans la plage DHCP ... faire le NAT sur cette IP.

En tout cas, le comportement du module est assez bizarre côté réseau.
Le site du fournisseur ... à Nivelles : https://www.domintell.com/ ... pas de zone de téléchargement, sauf pour les pros 😡

@roylion15 tes conseils sont toujours les bienvenus, ce n'est pas une incruste 😋
Niveau d'utilisateur 7
Le hic, comment savoir l'ip attribuée par le DHCP car je n'ai que le019 (mon pc portable dans les clients DHCP).
Bonsoir,

Juste une petite incursion dans ce sujet pour attirer l'attention sur le fait que l'affichage des clients DHCP est buggé dans le Technicolor.
Il peut falloir un certain temps ( et même un temps certain ) pour que tous les clients DHCP soient bien affichés après un redémarage du modem.
Cependant ces clients ont bien reçu leur IP et donc pas de problème autre que l'affichage.

Eteindre et rallumer les périphériques concernés permet parfois de les retrouver immédiatement dans la liste des clients DHCP mais parfois pas selon "le bon vouloir" du modem.
C'est du moins le cas avec mon exemplaire de ce modem ….
Badge +1
La fixe est ok mais pas celle qui doit clignoter.
Hier en ip fixe, elle clignotait correctement et mon appli fonctionnait.
Je vais voir avec le fournisseur du module.
Vous avez 2 leds, une fixe (indique la connexion physique du réseau) et celle qui devrait clignoter (indique du trafique sur le réseau) ?

Si c'est un bug connu du fournirsseur il devrait y avoir un nouveau firware pour ce module ... mais là il faut chercher comment le flasher dans le module.
Badge +1
En tout cas, j'en apprends pas mal… merci
Badge +1
J'ai refait la manœuvre avec un Factory reset (en appuyant dans le trou à l'arrière du modem). Il n'y a plus d'IP 100.
Le hic, comment savoir l'ip attribuée par le DHCP car je n'ai que le019 (mon pc portable dans les clients DHCP). De plus, la petite led verte à côté du RJ45 de mon module ne clignote pas comme si il ne communiquait pas.
Serait un bug de mon module en DHCP car il communique bien lorsque je force une IP fixe à la place du DHCP?
Si votre module est en DHCP, il ne devrait plus avoir l'IP 100 !! vérifier avec un ping.
Quelle adresse il aura obtenu ???

Après l'avoir mit en DHCP : reboot du module ... il devrait questionner le routeur pour recevoir une IP !

N'oubliez pas ensuite de reconfigurer la réservation et le NAT, comme expliqué avant.

Faites un ping sur l'IP réservée pour vérifier une fois tout en ligne ... cela devrait répondre si le module a bien reçu l'IP du modem 😉
Badge +1
Re,
Je viens de faire la manœuvre de Roylion: débranché le module, remettre les paramètres d'usine du modem, activé le Upnp puis rebranché mon module. Ou puis-je voir l'IP du module? Je ne la vois pas dans les client DHCP…
Le port 17481 est bien le port par défaut du module.

Hier, lorsque j'avais décoché DHCP dans mon module et forcé une ip fixe 192.168.0.100, j'arrivais y accéder en local sur mon appli; mais pas à distance. Le ping fonctionnait bien sur l'ip fixe 100.
Bon, il faudrait tout recommencer à 0, vous connaissez maintenant comment faire ... mdr

  1. Mettre votre module en DHCP et l'éteindre
  2. Faire un Factory défaut du modem : enfoncer une petite pointe dans le petit trou à l'arrière du modem durant un certain temps, attendre le reboot et modem en ligne
  3. Reconfigurer la réservation d'IP du DETH02 dans le modem, ainsi que le NAT (activer l'uPNP, on ne sait jamais)
  4. Reboot du modem
  5. Redémarrer le DETH02 dès que le modem est de nouveau en ligne (vérifiez s'il a la bonne adresse IP)
  6. Tester votre APP
Dites-nous quoi ... 😉
L'ip du module dans la place DHCP d'origine comme le suggère @roylion15
Niveau d'utilisateur 7
Badge +12
Hello
Je ne vois qu’une chose c’est que vous avez remis exactement les mêmes paramètres qu’ avant donc cela ne sert à rien...
reset factory et ne pas restaurer les paramètres
donc pas toucher à ipv6 / plage dhcp / etc ..
Votre centrale a toujours cette adresse en .100 .. pas normal...
Badge +1
Bonjour,
On s'y remet.
Adresse IP Publique ok 217.xxx
Réservation de l'IP 192.168.0.100 pour le module avec son adresse mac ok. Module en DHCP ok
NAT ok pour le module.
UPnP désactivé
Mais ca ne fonctionne toujours pas...je désespère.
Ci après une copie d'écran des étapes ci dessus:







Je vais essayer en activant UPnP...
Ce port est celui par défaut du module, c'est dans la doc que j'ai pu lire.

Je ne comprend pas non plus pourquoi cela ne fonctionne pas ... un moment donné il n'arrive plus à atteindre le module avec le ping 🤓
La configuration réseau du module est tout à fait bizarre 🤔
L'IPv6 ce n'est uniquement parce que ce module battait de l'aile, enlever une composante non utilisée.

Recommencer à zéro me semble être une bonne idée, si le factory défaut du Technicolor aide, je ne comprendrai jamais ce modem.
Niveau d'utilisateur 7
Badge +12
Hello
Je vois la beaucoup de chipoteries ...ce n’est pas la faute d’ IPv6 en tout cas.
Mon conseil ....
configurer votre central en dhcp , la couper électriquement un moment , le temps de faire une réinitialisation d’usine du modem .... le laisser redémarrer et activer upnp uniquement ensuite rallumer et rebrancher votre centrale et vous noterez l’ip de connexion locale de la centrale.
réserver cette IP sans la changer dans le dhcp réservation modem et recréer votre règle de NAT ...
Une autre question : ce port, 17481 c’est par défaut ou vous avez mis n’importe quoi ?

Tout cela doit fonctionner directement.
@DDA, il se fait tard et je bosse demain.
Merci pour votre aide. Je continuerai demain
Bonne nuit

Je comptais faire de même 😋

Vous pourriez tout de même essayer en IP fixe demain ... ce n'est pas l'idéal avec les modem de VOO, mais je suis presque certain que cela fonctionne également avec le Technicolor, les autres c'est moins sur.
En résumé :
  • Vous avez une IP publique
  • Vous avez fait une réservation d'IP pour le module, qui est en DHCP
  • Vous avez fait le NAT pour le port du module
  • Vous êtes en IPv4
Tout est réuni pour que cela fonctionne ...

Il ne reste plus qu'à activer l'uPNP : Routeur - Options -> dernier choix -> reboot du module

Pour augmenter votre sécurité :
Si cela fonctionne, l'idéal sera de ne pas prendre le port standard du fabriquant ... looool
Bien changer le mot de passe d'origine ... pas trop simple
Badge +1
@DDA, il se fait tard et je bosse demain.
Merci pour votre aide. Je continuerai demain
Bonne nuit
Badge +1
Oui le 019 est mon pc donc le ping sur le 100 ne fonctionne plus
C'est probablement votre PC ... en DOS : ipconfig pour connaître l'IP du PC
Badge +1
Je l'ai passé en ipV4 et il a rebooté.
Bizarre lors du test ping sur le 100, il mentionne: Réponse de 192.168.0.19 !!!!
Ne vous fier pas à cela, j'ai pu constater que ce n'est pas toujours complet ...

Le ping ? ... le seul vrai test.

Le ping sur le module fonctionne maintenant ?

Une autre chose à essayer : ne travailler qu'en IPv4, chez vous IPv4 et IPv6 sont activés.
Dans le modem : Etat - Mode routeur ... il va rebooter

Commenter