Passer au contenu principal
P

jeu. 10 janv. 2019 08:26

Permettre le Content Server de Calibre Library sur Mon Mac d'être joignable de l'internet

Bonjour, je possède un MacBook et sur celui ci j'ai un ensemble de livres pdf que j'utilise avec le logiciel Calibre Library.

Calibre permet de générer un serveur de contenu qui devrait être accessible de l'internet aussi.

Mais voilà, je n'arrive pas à configurer mon routeur Voo pour y accéder de l'internet.

Calibre spécifie qu'il faut forwarder sur le router le port 8080 (enable port forwarding on the router to forward the port 8080).

Je n'ai aucune option pour faire ca sur mon routeur car elle n'apparait pas et c'est déjà bizarre ca. Voici ce que j'ai après l'option NAT, directement l'option DMZ et pas l'option pour forwarder.

Comment puis je accéder ce serveur de contenu depuis l'internet?

Merci d'avance.

Réponses

DDA

Expert

 • 

3K Messages

il y a 2 ans

Voici le Nat du routeur Voo:

J'ai mis l'adresse IPv4 du routeur ... est ce bon ?

Vous voulez dire du aiport ?
Vous ne parliez pas du port 8080 ? ... utiliser le port 80 qui est le port standard HTTP n'est pas une bonne idée

le logiciel "Calibre Library." ne peut pas être configuré sur un autre port, ex. 81 ou 8080... ?
Techicolor - Trio Wahoo - 2 Evasion - 1 CI + - Essaie de trouver des alternatives aux distributions GAFAM
roylion15

Top Expert

 • 

18.1K Messages

il y a 2 ans

De toute façon la règle nat est fausse ça ne marchera jamais...
vous devez rediriger vers l’ip locale du serveur

VOO PACK « QUATRO MAX » | TECHNICOLOR CGA4233 "Mode Bridge" | Routeur ASUS : AX11000 | AiMESH : ASUS AC5300 | TV Samsung 65JS9500 + 55HU8500 | Nvidia Shield PRO | Xiaomi MI box S | Box Evasion | 2x Voobox | CI+ VOO

DDA

Expert

 • 

3K Messages

il y a 2 ans

De toute façon la règle nat est fausse ça ne marchera jamais...
vous devez rediriger vers l’ip locale du serveur

En plus :wink:
Techicolor - Trio Wahoo - 2 Evasion - 1 CI + - Essaie de trouver des alternatives aux distributions GAFAM
roylion15

Top Expert

 • 

18.1K Messages

il y a 2 ans

VOO PACK « QUATRO MAX » | TECHNICOLOR CGA4233 "Mode Bridge" | Routeur ASUS : AX11000 | AiMESH : ASUS AC5300 | TV Samsung 65JS9500 + 55HU8500 | Nvidia Shield PRO | Xiaomi MI box S | Box Evasion | 2x Voobox | CI+ VOO

14 Messages

il y a 2 ans

merci à vous deux déjà pour toutes ce informations. Je pense que c'est l'agencement de celles ci avec les bons paramètres de mes adresses mac et IP qui pourront solutionner mon problème en effet.

Je ne dois pas encore avoir réussi à mettre la bonne séquence d'adresses et je vais ré-essayer encore jusqu'à obtenir ce que je souhaite (que cela fonctionne). ;-)

Je vous tiens au courant. Merci.

14 Messages

il y a 2 ans

Bon... je n'arrive a rien ... impossible d'accéder de l'internet alors que dans le réseau local de la maison ca marche.

Sur mon Macbook, le serveur de contenu calibre une fois activé me donne une adresse ip avec port comme 192.168.0.11:9090 J'essaie avec cet autre port mais ca ne donne rien de neuf.

J'ai juste mis cette règle dans le NAT comme mon Airport est en mode bridge derrière le Voo Technicolor routeur et que je n'ai pas de firewall activé pour l'instant :

Question subsidiaire, comment se fait il que je ne vois pas le menu "redirection de port" à gauche en dessous du menu NAT ? Impossible de la voir !

DDA

Expert

 • 

3K Messages

il y a 2 ans

Sur mon Macbook, le serveur de contenu calibre une fois activé me donne une adresse ip avec port comme 192.168.0.11:9090 J'essaie avec cet autre port mais ca ne donne rien de neuf.

Si cette adresse qu'il tente de connecter par défaut, dans votre NAT, mettre 9090 au lieu de 90.
Remarque importante, l'adresse IP externe doit rester à 0.0.0.0 !!!
Cela est indiqué dans le Tuto que roylion15 avec mit en lien : laisser par défaut
Techicolor - Trio Wahoo - 2 Evasion - 1 CI + - Essaie de trouver des alternatives aux distributions GAFAM

14 Messages

il y a 2 ans

Je n'arrive pas a voir l'option "redirection de port" sous le menu NAT à gauche. Pouvez vous me dire ce que je peux faire pour enfin voir cette option? c'est dingue ca quand même, j'ai l'impression d'être le seul à pas voir cette option ;-(
DDA

Expert

 • 

3K Messages

il y a 2 ans

Heuuuu, je ne comprenais pas ce que vous vouliez dire.
Je suis donc retourné dans le tuto ... en effet ce menu y est visible, mais rassurez-vous, je ne l'ai pas non plus :laughing:... sans doute avec une version plus ancienne du Technicolor
Ne tenez pas compte de ce menu, c'est via NAT que vous devez travailler :yum:



Voici un exemple pour le port 80, remplacez par 9090 ... et Both pour le protocole (ne sachant pas si c'est du TCP ou UDP, en mettant Both, les 2 fonctionneront).
Le tuto dit de laisser les ports début et fin externe par défaut, en y mettant le port cela fonctionne également, je ne sais donc pas avec certitude si c'est à faire ou pas :wink:
En tout cas, moi je fais comme dans mon exemple et cela fonctionne !

Edit:
Renseignez-vous bien sur le port à utiliser, nous sommes avec le 8080 et 9090 ... tant que le bon port ne sera pas ouvert, cela ne fonctionnera probablement pas :kissing_smiling_eyes:
Techicolor - Trio Wahoo - 2 Evasion - 1 CI + - Essaie de trouver des alternatives aux distributions GAFAM

14 Messages

il y a 2 ans

Bon, je fais exactement comme vous dites. J'ai calibre avec l'adresse 192.168.0.11:9090

et dans le NAT je met:


ET donc par exemple sur mon mobile en wifi local, ca marche mais si je teste en désactivant le wifi pour qu'il se mette en data et donc en mode internet vers calibre alors rien ne marche plus. Dites moi si vous avez l'écran d'accueil utilisateur/mot de passe quand vous essayez avec cette adresse? Je ne comprends pas se qui bloque, ca semblait pourtant simple...

14 Messages

il y a 2 ans

Ah bon. ET si je comprend bien, je dois utiliser l'adresse IPv4 que je trouve dans l'option WAN sous Réseau ? c'est ca? et ca va router sur l'adresse du Mac sur lequel Calibre tourne avec ce port ou ?

14 Messages

il y a 2 ans

YES! ca marche semble t il ;-) ouf enfin. Je vais tester encore cela. Merci.
DDA

Expert

 • 

3K Messages

il y a 2 ans

Nickel, ce n'est pas difficile dès que toutes les conditions sont réunies :yum:
Si tout est OK, pouvez-vous indiquer quel post vous a aidé pour les autres clients dans le même cas :wink:
Techicolor - Trio Wahoo - 2 Evasion - 1 CI + - Essaie de trouver des alternatives aux distributions GAFAM

14 Messages

il y a 2 ans

Merci encore à vous deux. Oui, je viens de l'indiquer. Bon week-end.