Promeneur

 • 

18 Messages

mer. 26 oct. 2016 07:09

Routeur Voo ==> Switch ==> PC

Bonjour à tous,

J'ai mon Modem VOO dans une pièce avec deux pc branchés dessus.

J'ai tiré un câble (encastré dans le mur, j'ai crée les fiches RJ45 avec le code couleur suivant des deux cotés : blanc/orange, orange, blanc/vert, bleu, blanc/bleu, vert, blanc/marron, marron) du modem vers mon salon.

Dans mon salon si je branche un pc sur mon nouveau câble, ce fonctionne nickel !

Par contre si je branche un switch puis que je mets la box évasion et mon pc, rien ne vas.

Autre truc étrange ... Si je remplace mon câble encastré par des CPL ça fonctionne, (mais les CPL ne sont pas assez rapide, donc ce n'est pas une solution envisageable pour moi.)

Avez-vous des idées ?

Merci d'avance !

Réponses

Solution acceptée

Promeneur

 • 

18 Messages

il y a 4 ans

J'ai chercher longtemps pour mon problème, j'avais une inversion de câble dans ma prise.


Vous avez pourtant dit que ça ne fonctionnait pas non plus avec un câble du commerce...


Effectivement, j'avais essayé et ça ne fonctionnais pas. J'avais pris un câble de 20M du boulot.

Je viens d'essayer ce câble sur mon pc au boulot, résultat : Il est à la poubelle.

J'ai eu de la chance sur ce coup la ..
MisterX

Expert

 • 

1.9K Messages

il y a 4 ans

Bonjour sebcircle2,

Si vous avez connecté les 2 fiches rj45 de la même manière, vous avez un câble "droit" et ça explique que ça fonctionne avec un ordinateur, mais pas avec votre switch. Il faudra fabriquer un câble "croisé" pour résoudre votre problème.

Cordialement.


X
Je suis capable du meilleur et du pire. Mais, dans le pire, c'est moi le meilleur.

Promeneur

 • 

18 Messages

il y a 4 ans

Bonjour sebcircle2,

Si vous avez connecté les 2 fiches rj45 de la même manière, vous avez un câble "droit" et ça explique que ça fonctionne avec un ordinateur, mais pas avec votre switch. Il faudra fabriquer un câble "croisé" pour résoudre votre problème.

Cordialement.

X


Merci MisterX

Heu ... J'ai lu sur internet qu'entre un routeur et un switch on doit toujours utilisé un câble droit..

Un routeur à une interface MDI, un switch une interface MDIX. Pour relier du MDI à MDIX on utilise du droit non ?

Je vais tout de même essayer ce soir de "croiser" le câble. Comment je doit m'y prendre ? Je doit changer que d'un coté ? Quel code couleur ?

Normalement les câbles encastrés dans les maisons sont droits ou pas ?

Merci d'avance
Marcs

Top Expert

 • 

10.9K Messages

il y a 4 ans

Bonjour,

Voir aussi si le switch est droit ou croisé.
J'avais eu le coup lors de l'installation (ce n'était pas un switch mais une fiche F/F pour prolonger un câble trop court) le remplacement de ce connecteur a résolu le problème.

Avez vous testé le pc seul sur le switch ? (sans switch ça fonctionne si j'ai bien suivi) et la box seule avec et sans switch ?
N'étant qu'un simple client, je ne parle jamais au nom de Voo
MisterX

Expert

 • 

1.9K Messages

il y a 4 ans

Vous trouverez plus d'explications ici : http://cisco.goffinet.org/s1/straight-cross_cables
Je suis capable du meilleur et du pire. Mais, dans le pire, c'est moi le meilleur.
pthierry

Citoyen d'honneur

 • 

2.4K Messages

il y a 4 ans

Normalement tous les switches gigabit (et même 100 Mbps) devraient pouvoir fonctionner avec les 2 types de câble (fonction Auto MDI-X). J'en ai connecté au moins 5 types différents sur le Netgear avec des câbles standards.

Sur les anciens switchs, il y a un des connecteurs qui peut être configuré pour connecter un autre switch (généralement à l'aide d'un interrupteur)

Pour en être sûr, essayez simplement de connecter le switch sur le modem avec un câble du commerce...

Promeneur

 • 

18 Messages

il y a 4 ans

Bonjour,

Voir aussi si le switch est droit ou croisé.
J'avais eu le coup lors de l'installation (ce n'était pas un switch mais une fiche F/F pour prolonger un câble trop court) le remplacement de ce connecteur a résolu le problème.

Avez vous testé le pc seul sur le switch ? (sans switch ça fonctionne si j'ai bien suivi) et la box seule avec et sans switch ?


J'ai recommencer les fiches pour être sur que le problème ne vienne pas de la mais non c'est bon.
Le PC Seul c'est bon.
La box seule c'est bon.

L'un ou l'autre (ou les deux) avec le switch entre, ça ne fonctionne plus.

Promeneur

 • 

18 Messages

il y a 4 ans

Vous trouverez plus d'explications ici : http://cisco.goffinet.org/s1/straight-cross_cables


Sur le site que vous me donnez ils disent d'utiliser un câble droit entre un routeur et un switch. J'ai donc le bon câble. Je suis un peu perdu :/

Promeneur

 • 

18 Messages

il y a 4 ans

Normalement tous les switches gigabit (et même 100 Mbps) devraient pouvoir fonctionner avec les 2 types de câble (fonction Auto MDI-X). J'en ai connecté au moins 5 types différents sur le Netgear avec des câbles standards.

Sur les anciens switchs, il y a un des connecteurs qui peut être configuré pour connecter un autre switch (généralement à l'aide d'un interrupteur)

Pour en être sûr, essayez simplement de connecter le switch sur le modem avec un câble du commerce...


Bonjour Thierry,

C'est un switch automatique (TP-LINK TL-SF1005D) Il fonctionne avec les deux câbles. (Et le switch fonctionne puisque ca fonctionne avec les CPL)

J'ai essayé avec un câble du commerce, ça ne fonctionne pas non plus ....
pthierry

Citoyen d'honneur

 • 

2.4K Messages

il y a 4 ans

Très curieux... Remarque en passant: c'est un switch 100 Mbps, vous allez donc limiter la vitesse disponible pour votre PC...

Un câble droit sert à connecter un PC à un switch/hub.

https://fr.wikipedia.org/wiki/RJ45#C.C3.A2blage_crois.C3.A9_complet
pthierry

Citoyen d'honneur

 • 

2.4K Messages

il y a 4 ans

Perso je pense que vous devriez changer de switch... Cela fait longtemps que l'on a plus à se soucier d'utiliser un câble droit ou croisé. A la construction de mon appartement, j'ai fait tirer un câble entre 2 pièces, et je n'ai jamais eu de problème pour y connecter un PC directement, et plus tard un switch...

Promeneur

 • 

18 Messages

il y a 4 ans

Perso je pense que vous devriez changer de switch... Cela fait longtemps que l'on a plus à se soucier d'utiliser un câble droit ou croisé. A la construction de mon appartement, j'ai fait tirer un câble entre 2 pièces, et je n'ai jamais eu de problème pour y connecter un PC directement, et plus tard un switch...


Il est tout neuf .. Je l'ai acheté vendredi passé...
Marcs

Top Expert

 • 

10.9K Messages

il y a 4 ans

J'ai recommencer les fiches pour être sur que le problème ne vienne pas de la mais non c'est bon.
Le PC Seul c'est bon.
La box seule c'est bon.

L'un ou l'autre (ou les deux) avec le switch entre, ça ne fonctionne plus.


Donc a priori, c'est bien le switch qui pose problème.
N'étant qu'un simple client, je ne parle jamais au nom de Voo
pthierry

Citoyen d'honneur

 • 

2.4K Messages

il y a 4 ans

Il est tout neuf .. Je l'ai acheté vendredi passé...


Je ne dis pas le contraire, mais:
1) Il n'est que 100 Mbps, c'est dommage de vous limiter dès le départ
2) Bien qu'il soit Auto MDI/MDI-X (ils le répètent à de nombreux endroits sur la présentation du produit) pour une raison ou pour une autre, cela ne semble pas fonctionner avec le modem, même avec un câble du commerce...

Le fait que cela fonctionne avec du CPL indique que la négociation Modem/CPL et CPL/switch se passe bien...

Promeneur

 • 

18 Messages

il y a 4 ans

Je vais essayer ce soir avec un câble croisé. Je vais suivre le schéma ci-joint. Il a l'air bon ?

Si cela ne fonctionne toujours pas, je changerais le switch.

Je vous tiens au courant !