Passer au contenu principal
C

Promeneur

 • 

29 Messages

dim. 22 sept. 2019 08:04

Impossible d'accéder à mon serveur Ubuntu de l'extérieur de mon réseau privé

Bonjour,

J'ai installé un serveur ubuntu chez moi. Je peux y accéder via un ordi de mon réseau privé mais pas via internet.
J'ai ouvert les ports du firewall sur ma machine Ubuntu (notamment le port 22 pour ssh).
J'ai configuré le mapping des ports dans le modem VOO via l'url : http://192.168.0.1/RgForwarding.asp
J'ai défini en DMZ l'ip de mon serveur Ubuntu via l'url http://192.168.0.1/RgDmzHost.asp mais je ne sais pas si cela est vraiment nécessaire.
J'ai désactivé "Blocage Wan" via l'url http://192.168.0.1/RgOptions.asp mais je ne sais pas si cela est vraiment nécessaire

Voici des commandes exécutées pour vérifier certains points :

Le ping via l'extérieur fonctionne (en 4G) :
ping 109.xx.xx.xx
PING 109.xx.xx.xx (109.xx.xx.xx) 56(84) bytes of data.
64 bytes from 109.xx.xx.xx: icmp_seq=1 ttl=50 time=60.2 ms
64 bytes from 109.xx.xx.xx: icmp_seq=2 ttl=50 time=49.1 ms

Le ssh en réseau local fonctionne :
ssh xxxx@192.168.0.24
xxxxx@192.168.0.24's password:
Welcome to Ubuntu 19.04 (GNU/Linux 5.0.0-29-generic x86_64)

Par contre j'ai un timeout pour un ssh via l'extérieur

Voici les ports ouverts sur mon firewall :
sudo ufw status verbose
[sudo] Mot de passe de xxx :
État : actif
Journalisation : on (low)
Par défaut : allow (incoming), allow (outgoing), disabled (routed)
Nouveaux profils : skip

Vers Action De
---- ------ --
22 ALLOW IN Anywhere
1337 ALLOW IN Anywhere
80 ALLOW IN Anywhere
80/tcp ALLOW IN Anywhere
22 (v6) ALLOW IN Anywhere (v6)
1337 (v6) ALLOW IN Anywhere (v6)
80 (v6) ALLOW IN Anywhere (v6)
80/tcp (v6) ALLOW IN Anywhere (v6)


Est-ce que j'ai oublié de faire quelque chose d'autre ?

Merci et bonne journée
Chirstophe

Réponses

Solution acceptée

pthierry

Citoyen d'honneur

 • 

2.4K Messages

il y a un an

Bonjour,

Essayez avec 0.0.0.0 pour l'adresse externe.
roylion15

Top Expert

 • 

17.2K Messages

il y a un an

Hello
désactivez DMZ ...
blocage wan sert à pour faire des pings de l’extérieur sur le modem mais bon pour un test mais ne pas laisser par après

postez une capture de votre réglages NAT svp
vérifiez ce point important
VOO PACK « QUATRO MAX » | TECHNICOLOR TC7210 "Bridge" | Routeur ASUS : AX11000 | AiMESH : ASUS AC5300 | TV Samsung 65JS9500 + 55HU8500 | Nvidia Shield PRO | Box Evasion | Voobox | CI+ VOO

Promeneur

 • 

29 Messages

il y a un an

Bonjour,

Oui j'ai bien une IP publique.
J'ai désactivé le DMZ.
J'ai supprimé le blocage Wan
Voici mon régalge NAT.

Merci

DDA

Expert

 • 

3K Messages

il y a un an

Oui l'adresse externe DOIT être 0.0.0.0

Pour votre serveur, comment avez vous fixé son adresse ? ... IP fixe ou réservation d'IP via la MAC adresse ?

Avec les modem VOO, la 2me solution est la plus fiable.

Il y a-t-il une raison que vous changiez le port 1337 ?
Techicolor - Trio Wahoo - 2 Evasion - 1 CI + - Essaie de trouver des alternatives aux distributions GAFAM
roylion15

Top Expert

 • 

17.2K Messages

il y a un an

l'erreur c'est effectivement qu' il ne faut rien mettre en IP externe laisser 0.0.0.0

Pourquoi vous redirigez vers le 8080 , votre serveur web écoute sur ce port ?
Je déconseille ce port 8080 car le modem peut l'utiliser pour certaines fonctions de diagnostic et donc vous risquez un conflit.
VOO PACK « QUATRO MAX » | TECHNICOLOR TC7210 "Bridge" | Routeur ASUS : AX11000 | AiMESH : ASUS AC5300 | TV Samsung 65JS9500 + 55HU8500 | Nvidia Shield PRO | Box Evasion | Voobox | CI+ VOO
DDA

Expert

 • 

3K Messages

il y a un an

Pourquoi vous redirigez vers le 8080 , votre serveur web écoute sur ce port ?
Je déconseille ce port 8080 car le modem peut l'utiliser pour certaines fonctions de diagnostic et donc vous risquez un conflit.

Si c'est le cas, ce port peut-être modifier dans la configuration du serveur lui-même ... 8080 est souvent utilisé par défaut pour les serveur web , mais rien n'oblige de le garder.

Vous avez configuré 1337, il peut rester identique en externe et en interne ... d'où ma question de la raison de ce changement de port avec le NAT.

roylion15 c'est l'externe qui est 8080, interne c'est 1337 ... ta réponse est encore plus pertinente du coup !
Techicolor - Trio Wahoo - 2 Evasion - 1 CI + - Essaie de trouver des alternatives aux distributions GAFAM

Promeneur

 • 

29 Messages

il y a un an

Merci à tous pour votre aide.
Cela fonctionne en mettant l'ip externe à 0.0.0.0

J'avais testé le port 8080 car le port 22 et 80 ne fonctionnaient pas. Je ne vais plus l'utiliser.


Bonne journée
DDA

Expert

 • 

3K Messages

il y a un an

Super que cela fonctionne maintenant, content que le forum ai pu régler votre problème.

Attention que pour un serveur web, c'est le UP qui est le plus important, surtout si beaucoup consulté ... c'est le serveur qui retourne la page au client :wink:
Techicolor - Trio Wahoo - 2 Evasion - 1 CI + - Essaie de trouver des alternatives aux distributions GAFAM

Promeneur

 • 

29 Messages

il y a un an

Super que cela fonctionne maintenant, content que le forum ai pu régler votre problème.

Attention que pour un serveur web, c'est le UP qui est le plus important, surtout si beaucoup consulté ... c'est le serveur qui retourne la page au client :wink:


C'est quoi l'UP ?

Bonne soirée
Gerinald

Citoyen d'honneur

 • 

7.6K Messages

il y a un an


C'est quoi l'UP ?

Bonne soirée



Bonsoir,

UP = upload :)

Bonne soirée
Rien ne sert de courir, tout viens à point à qui sait attendre. Abonnement One – Décodeur Evasion et modem Technicolor