Safari/El Capitan, Firefox/Snow Leopard et CGN ne font pas bon ménage [résolu]


Niveau d'utilisateur 6
Badge +7
Depuis plusieurs mois, nos deux MacBook Pro posaient problème lors d'accès à Internet. Ceux-ci sont connectés à Internet via une Airport Extreme, le Netgear étant configuré en mode bridge.
Avec le premier (toujours sous Snow Leopard), avec certains sites accès Internet très lent et téléchargement d'images fastidieux sous Firefox. Supprimer IPV6 a résolu le problème mais cette solution posait question car tout fonctionnait très bien auparavant et rien n'avait changé dans la configuration.
Avec le deuxième (El Capitan), sous Safari, accès aléatoire à certains sites (Google, Youtube et autres). Selon le moment de la journée, il fallait renouveler l'opération 4 à 5 fois avant d'obtenir une réponse. J'ai tout investigué dans la config du Mac et de l'Airport Extreme sans aucun résultat positif.
Comme Firefox ne posait absolument aucun problème, j'ai contacté le forum des utilisateurs Mac mais sans succès.
Donc problème avec Firefox en IPV6 activé sous Snow Leopard avec le premier et aucun souci avec Safari, problème avec Safari sous El Capitan avec le deuxième et aucun souci avec Firefox. Chercher l'erreur !!!
Et puis, je suis tombé sur un post de Roylion15 traitant de CGN et des problèmes éventuels. J'avais bien noté que l'Airport indiquait double NAT mais je n'y avais pas prêté attention.
Adrien a très rapidement répondu à ma demande de repasser à une IP publique et ô miracle, le problème avec le deuxième MacBook Pro est disparu. Je n'ai pas encore essayé de repasser en IPV6 avec le premier mais je suis certain que ce problème est également disparu.
Pour répondre à Tiou (dans un autre post), il n'est pas évident du tout que les clients qui éprouvent des problèmes de ce type contacteront le support technique de VOO car ils devraient d'abord comprendre l'incidence d'un CGN sur le protocol Internet (qui peut varier d'une config à l'autre et d'un navigateur Internet à l'autre).

Encore merci à Roylion15 pour m'avoir mis la puce à l'oreille et à Adrien pour sa prompte réaction. 🙂

2 commentaires

Badge +14
Et bien, j'ai voulu passer à El Capitan et je me suis demandé si on en avait déjà parlé ici 😃

Vous avez le lien vers le post de roylion à ce sujet ?
Niveau d'utilisateur 6
Badge +7
Bonjour Nicolas,

Je ne retrouve plus le post de Roylion15. Il n'était pas à proprement parler spécifique à Safari ou El Capitan, mais plutôt générique quant à l'impact éventuel d'un CGN et d'un double NAT.
Quant à El Capitan, aucun problème après 2 mois d'utilisation. J'avais fait une sauvegarde complète au préalable avec CCC mais elle s'est avérée inutile.

Commenter