Promeneur

 • 

29 Messages

mar. 28 nov. 2017 19:38

Ping mon ip extérieure

Bonjour, je ne suis pas à la maison pour le moment afin de faire un 'ping' vers mon adresse ip.
Comme j'ai l'intention de configurer un serveur apache sur un raspberry, je voulais m'assurer du bon accès à mon réseau.
Mon adresse ip est 109.88.xxx.xx : ping impossible!
Je pense avoir bien configuré le routeur .
Quand je fais un tracert, il bloque au 6ème saut sur 'host-212-68-211-74.dynamic.voo.be
Pouvez-vous m'aider?

Réponses

DDA

Expert

 • 

3K Messages

il y a 3 ans

Le serveur apache est bien configuré en externe, ou simplement local ?
J'utilise uWamp et je peux le mettre en Offline ou Online.
Je n'ai jamais approfondi les paramètres possible, sauf dans Mysql pour augmenter entre-autre la taille des fichiers uploadables.

EDIT : une piste : https://kgaut.net/blog/2010/configurer-wamp-pour-un-acces-depuis-le-reseau-local.html ou https://web.developpez.com/cours/serveur-web-chez-soi/
Techicolor - Trio Wahoo - 2 Evasion - 1 CI + - Essaie de trouver des alternatives aux distributions GAFAM

Promeneur

 • 

29 Messages

il y a 3 ans

Merci DDA pour ces infos.
Dans mon cas, apache n'est pas installé sur une machine Windows mais sur un Raspberry Pi3.
Il est online car j'y accède sans problème sur le LAN.
Mais, je voudrais pouvoir y accéder depuis l'extérieur.
J'ai installé Teamviewer sur le Raspi : aucun problème pour me connecter depuis internet; je peux ainsi accéder à tous mes dossiers et fichiers très facilement.
Problème: pourquoi apache n'est-il pas accessible par internet?
DDA

Expert

 • 

3K Messages

il y a 3 ans

Dans mon cas, apache n'est pas installé sur une machine Windows mais sur un Raspberry Pi3.

Cela ne change rien qu'apache a un fichier de configuration et il n'écoute probablement que le localhost ou 127.0.0.1.
Je suppose donc que tu dois tourner sur une distribution Linux, avec ton editeur tu peux alors modifier en Sudo ce fichier de config.
Le tout est de trouver son emplacement !
Techicolor - Trio Wahoo - 2 Evasion - 1 CI + - Essaie de trouver des alternatives aux distributions GAFAM

Promeneur

 • 

29 Messages

il y a 3 ans

oui, c'est vrai.
Il tourne sur Linux (Raspbian)
J'ai adapté les différents fichiers de configuration (hosts, *.conf...)
C'est ok en local mais pas vers l'extérieur....
Je continue mes recherches ! :)
DDA

Expert

 • 

3K Messages

il y a 3 ans

Les paramètres dans apache seront identiques que dans les liens plus haut, quelque que soit l'OS.
Il faut par après regarder le natting de port du routeur vers le Raspi ... qui devra être en IP fixe. Si c'est pour votre usage interne, je préconise le port 8080 au lieu de 80 ! (l'url sera alors "IP_internet: 8080", sans l'espace devant le premier 8 car sinon il y a un émoticone)
Ensuite il y a également le pare-feu du Raspbian à regarder (Debian je suppose) ... c'est également configurable (je crois qu'il y a 2 endroits possibles).

Je n'ai que très peu d'expérience en Linux, même si je connais les principes de base, il faut donc consulter ton meilleur ami G....e (ne faisons pas de pub ... mdr)
Techicolor - Trio Wahoo - 2 Evasion - 1 CI + - Essaie de trouver des alternatives aux distributions GAFAM

Promeneur

 • 

29 Messages

il y a 3 ans

Merci, je vais essayer de passer sur le port 8080.
Le Raspi est bien en ip fixe 192.168.1.20 et le port 80 est bien redirigé vers cette adresse ip.
Je vais rendre visite à mon"meilleur ami" G.. pour voir du côté du pare-feu du Raspi....
A plus tard pour d'autres nouvelles.

Promeneur

 • 

29 Messages

il y a 3 ans

Bon, c'est toujours le brouillard...!
Je suis reparti à zéro sur une nouvelle carte SD.
J'ai réinstallé Debian pour Raspberry ainsi que le serveur apache.
Tout est opérationnel sur mon LAN: le serveur est bien accessible depuis n'importe quel poste en local en tapant son ip.
Mon serveur apache est en ip fixe dans le LAN et, comme mon adresse ip externe est dynamique, j'utilise une HostName no-ip.
Le serveur écoute le port 80.
Dans le routeur, le port 80 est bien redirigé vers l'ip fixe du serveur.
Mon problème n'a pas changé: impossible d'accéder au serveur depuis un pc extérieur à mon LAN qui utilise mon Hostname No-Ip.
Je ne vois pas où se situe le "blocage"...
DDA

Expert

 • 

3K Messages

il y a 3 ans

No-IP se met bien à jour ? Mon expérience avec eux n'a pas été des meilleures.
Regarde ici si elles correspondent : http://www.mon-ip.com/ ... si déjà là cela bloque, il faut regarder la config chez No-IP et les paramètres DDNS du routeur.

Note que ton IP chez VOO ne change que très rarement, cela pose un problème avec les DDNS qui ont besoin de requête régulières sinon le service s'arrête. Il existe alors des pgm à installer sur le PC qui font ces requêtes d'une manière régulière.
Essaie de te connecter directement sur ton IP depuis la 4G par exemple.
Techicolor - Trio Wahoo - 2 Evasion - 1 CI + - Essaie de trouver des alternatives aux distributions GAFAM

Promeneur

 • 

29 Messages

il y a 3 ans

Merci DDA pour ces conseils.
Effectivement, je constate que VOO ne change pratiquement pas l'adresse ip. (je vérifie bien sur mon-ip.com)
J'ai fait le test suivant : je connecte en wifi mon pc portable sur un VOO_HOMESPOT avec mes identifiants VOO;
Je suis donc connecté à l'extérieur me semble-t-il ?
Je tape alors l'ip publique de ma box ou bien l'Hostname no-ip : erreur, le délai d'attente est dépassé.
Même résultat si je vais me connecter chez mon fils.
Comment faire ?
DDA

Expert

 • 

3K Messages

il y a 3 ans

Bon, je viens de faire le test avec mon serveur web ... pour moi c'est OK.

1. Côté NAT du routeur, voici comment tu dois faire



Il y a 9 chances sur 10 que tu as mit ton IP externe ... ben non, il ne faut pas !!! J'ai eu la blague pour une application utilisant un port spécial et c'est ici qu'on a donné la solution : https://forum.voo.be/mon-reseau-17/creer-un-port-forwarding-sur-router-tc7210-5883.
Moi j'ai utilisé le port 8xxx, si tu veux 8080 par exemple, tu mets 8080 partout où il y a 80 :P
En description, tu peux mettre un nom afin de te retrouver dans quelques temps ... loool

2. Côté de mon serveur, config apache (tu dois trouver l'emplacement pour toi, moi je n'ai qu'a passer de Offline à Online) :
paramètres chez moi :
Order allow,deny
Allow from all

3.de ton PC tu tape ton IP externe et cela arrive
Si tu as mit un autre port : ip externe:port

EDIT : je suis sous Windows, j'ai également du régler le pare-feu de laisser les connexion extérieures passer sur apache
Techicolor - Trio Wahoo - 2 Evasion - 1 CI + - Essaie de trouver des alternatives aux distributions GAFAM

Promeneur

 • 

29 Messages

il y a 2 ans

C'est exactement ce que j'ai fait !
Dans mon routeur , les requêtes http entrantes sont redirigées vers l'ip locale 192.168.1.20 du serveur apache en utilisant le port 80.
Je vais voir l'ip publique avec mon-ip.com : exemple, 109.88.abc.def. je connais ainsi mon ip publique.
Je vais sur un réseau extérieur au mien et je tape cette adresse : 109.88.abc.def dans mon browser.
je devrais alors tomber sur la page de mon serveur, comme je la trouve en local en tapant 192.168.1.20....
Au lieu de ça, j'ai un message qui s'affiche : "Adresse introuvable" !!!:@
DDA

Expert

 • 

3K Messages

il y a 2 ans

Adresse introuvable ?! ... heuuuu je dirai que cela bloque chez VOO ... @Support VOO, une idée ?

Quand rien n'est configuré pour mon serveur web, si je tappe mon IP, même de chez moi :

Cette page ne fonctionne pas

85.201.abc.def n'a envoyé aucune donnée.
ERR_EMPTY_RESPONSE
Techicolor - Trio Wahoo - 2 Evasion - 1 CI + - Essaie de trouver des alternatives aux distributions GAFAM
pthierry

Citoyen d'honneur

 • 

2.4K Messages

il y a 2 ans

C'est exactement ce que j'ai fait !
Dans mon routeur , les requêtes http entrantes sont redirigées vers l'ip locale 192.168.1.20 du serveur apache en utilisant le port 80.
Je vais voir l'ip publique avec mon-ip.com : exemple, 109.88.abc.def. je connais ainsi mon ip publique.
Je vais sur un réseau extérieur au mien et je tape cette adresse : 109.88.abc.def dans mon browser.
je devrais alors tomber sur la page de mon serveur, comme je la trouve en local en tapant 192.168.1.20....
Au lieu de ça, j'ai un message qui s'affiche : "Adresse introuvable" !!!:@


Pouvez-vous essayer d’ouvrir également le port 443 ? Il se pourrait que le serveur redirige vers une connexion https, mais c’est juste une supposition..
DDA

Expert

 • 

3K Messages

il y a 2 ans

Pouvez-vous essayer d’ouvrir également le port 443 ? Il se pourrait que le serveur redirige vers une connexion https, mais c’est juste une supposition..

Ha ben oui, je n'y avait pas pensé à celle-là :cool:
C'est dans la config d'apache également.

Toutefois, c'est bizarre qu'il mette "adresse introuvable", chez moi j'ai eu "accès refusé" quand la direction de port était correct et qu'apache bloquait les accès ... mais j'ai fait en HTTP, je ne penses pas que cela change pour l'HTTPS.
Maintenant, sans redirection de port, j'ai le message ci-dessus ... un timeout quoi
Techicolor - Trio Wahoo - 2 Evasion - 1 CI + - Essaie de trouver des alternatives aux distributions GAFAM

Promeneur

 • 

29 Messages

il y a 2 ans

Merci à vous deux, je vais essayer ce port 443 dans la journée dès que j'en aurai le temps.
Je vous tiens au courant.:?