Promeneur

 • 

34 Messages

lun. 11 févr. 2019 19:33

Connexion à distance à ma domotique impossible avec IP publique via dyndns

Bonjour,

Je fait appel à ce forum et sa communauté pour résoudre mon problème.
J'ai une installation domotique Domintell que je souhaite contrôler à distance. Pour cela, j'ai installé l'app sur mon portable et configuré leur module DETH02 (adresse IP 192.xxx et ouverture du port 17481).
Côté Voo, j'ai une adresse IP publique 217.xxx et les services dyndns du modem sont configurés. Le modem est en mode router.
Côté dyndns, je pointe bien vers l'adresse IP publique et tout est en ordre.
Côté app, l'adresse est celle de mon dyndns, l'IP locale est celle du DETH02 (192.xxx), le port est bien le 17481.
Lorsque je ping vers le DETH02 de mon pc portable, il répond bien donc il est bien reconnu dans mon réseau local.
Malgré cela, je n'arrive pas à me connecter à ma domotique aussi bien via mon wifi interne que via la 4G à distance…. cela fait plusieurs jours que je tourne en rond.
Est ce que quelqu'un pourrait m'aiguiller?
Merci
Vh57001

Réponses

roylion15

Top Expert

 • 

15.4K Messages

il y a un an

Hello
Si ça ne fonctionne pas en local déjà , il y a un problème...
Votre central domotique est il bien configuré en Dhcp ou non ?

cela fonctionne t-il en utilisant l’ip publique sans passer par dyndns ?
Le dyndns avec une connexion voo est pratiquement inutile vu que l’ip est semi-fixe ne change pratiquement jamais.

Sinon postez nous un screen de votre règle de nat et de la config réseau de votre central afin de voir si qqch cloche ...
VOO PACK « QUATRO MAX » | TECHNICOLOR TC7210 "Bridge" | Routeur ASUS : AX11000 | AiMESH : ASUS AC5300 | TV Samsung 65JS9500 + 55HU8500 | Nvidia Shield PRO | Box Evasion | Voobox | CI+ VOO
DDA

Expert

 • 

3K Messages

il y a un an

Avez-vous fait un test du module ?
To know the IP address of the network, use the tool diagnosis: The software GdethTesteror the menu ETH DIAGNOSTIC present on the master (DGQG01)

Il serait bon de vérifier les paramètres IP du module, voir s'il n'y a pas de conflit d'IP ...

Avec les modem VOO, il vaut mieux être en DHCP avec réservation d'IP via la MAC et faire le NAT sur cette IP réservée :wink:

En local, vu le port, je me demande si vous ne devez pas configurer votre pare-feu pour l'autoriser.
ou taper http://IP_DETH02:17481... voir https s'il l'accepte.
En http, certains navigateurs risquent de demander une exception vu que l'https est devenu le standard.
Techicolor - Trio Wahoo - 2 Evasion - 1 CI + - Essaie de trouver des alternatives aux distributions GAFAM

Promeneur

 • 

34 Messages

il y a un an

Déjà merci à vous pour l'aide.

En remplaçant l'adresse dyndns par l'adresse locale 192.xxx, cela fonctionne sans problème par le Wifi.
Par contre, cela ne marche pas avec l'adresse ip publique 217.xxx.
Je n'ai pas de règle NAT v screen ci après.
Merci.
DDA

Expert

 • 

3K Messages

il y a un an

Faites votre NAT sur le port 17481 vers l'IP du DETH02



Ici un exemple du port 80 vers l'IP 192.168.1.20 ... mettez vos paramètres, l'IP Externe reste 0.0.0.0 !!
Pour le protocole, voir le manuel, au pire mettre Both (TCP et UDP).
Ne pas oublier de l'activer.
Techicolor - Trio Wahoo - 2 Evasion - 1 CI + - Essaie de trouver des alternatives aux distributions GAFAM
roylion15

Top Expert

 • 

15.4K Messages

il y a un an

Ha !
Dans votre message initial, pourtant vous dites avoir ouvert le port en question ?
Alors effectivement sans une règle de NAT sur ce port dans le modem, cela ne fonctionnera jamais de l’extérieur...
VOO PACK « QUATRO MAX » | TECHNICOLOR TC7210 "Bridge" | Routeur ASUS : AX11000 | AiMESH : ASUS AC5300 | TV Samsung 65JS9500 + 55HU8500 | Nvidia Shield PRO | Box Evasion | Voobox | CI+ VOO
DDA

Expert

 • 

3K Messages

il y a un an

Dans votre message initial, vous dites avoir ouvert le port en question ?

Je crois qu'il l'a configuré dans le module, mais pas dans le modem :kissing_smiling_eyes:
Techicolor - Trio Wahoo - 2 Evasion - 1 CI + - Essaie de trouver des alternatives aux distributions GAFAM
roylion15

Top Expert

 • 

15.4K Messages

il y a un an

DDA
c’est bien possible mais ça prête à confusion .... ?
VOO PACK « QUATRO MAX » | TECHNICOLOR TC7210 "Bridge" | Routeur ASUS : AX11000 | AiMESH : ASUS AC5300 | TV Samsung 65JS9500 + 55HU8500 | Nvidia Shield PRO | Box Evasion | Voobox | CI+ VOO

Promeneur

 • 

34 Messages

il y a un an

On apprend tous les jours…
Voici la règle NAT mais cela ne change rien pour l'accès à distance…
roylion15

Top Expert

 • 

15.4K Messages

il y a un an

Hello
Vous êtes sur de l’adresse IP locale de votre centrale ?
Il me semble que normalement cette adresse 192.168.0.10 est utilisée par le modem ..
egalement dans l’appli il faut remettre l’ip publique 217.x
VOO PACK « QUATRO MAX » | TECHNICOLOR TC7210 "Bridge" | Routeur ASUS : AX11000 | AiMESH : ASUS AC5300 | TV Samsung 65JS9500 + 55HU8500 | Nvidia Shield PRO | Box Evasion | Voobox | CI+ VOO

Promeneur

 • 

34 Messages

il y a un an

Oui j'avais ouvert le port sur le module uniquement.
DDA

Expert

 • 

3K Messages

il y a un an

Vous êtes certain du protocole TCP ?
Dans le doute mettez les 2, il n'y a pas de gros risque de toute façon.

Votre IP me chagrine un peu, c'est la première du DHCP du modem.
Pour être certain, en commande DOS, faire un ping 192.168.0.10 -t (ping en continu) et le déconnecter, s'il y a "No reply", c'est bien lui ... CTRL + C pour arrêter le ping.

Avez-vous fait une réservation d'IP pour le module qui doit alors être en DHCP ?
Techicolor - Trio Wahoo - 2 Evasion - 1 CI + - Essaie de trouver des alternatives aux distributions GAFAM
DDA

Expert

 • 

3K Messages

il y a un an

Il me semble que normalement cette adresse 192.168.0.10 est utilisée par le modem ..

Le modem par défaut est 192.168.0.1 :kissing_smiling_eyes:
Vive l'utilisation de routeur personnel, on en oublie les bases ... :rofl:
Techicolor - Trio Wahoo - 2 Evasion - 1 CI + - Essaie de trouver des alternatives aux distributions GAFAM
roylion15

Top Expert

 • 

15.4K Messages

il y a un an

Hum, ça je sais bien ?
Ne pas déformer mes paroles stp ...je n’ai pas dit que cette adresse était celle du modem mais je pense qu’elle est souvent utilisée par le modem par le partage usb ou autre serveur de fichiers du modem car c’est la première IP du dhcp
VOO PACK « QUATRO MAX » | TECHNICOLOR TC7210 "Bridge" | Routeur ASUS : AX11000 | AiMESH : ASUS AC5300 | TV Samsung 65JS9500 + 55HU8500 | Nvidia Shield PRO | Box Evasion | Voobox | CI+ VOO

Promeneur

 • 

34 Messages

il y a un an

Re,
Oui je suis sûr mais par sécurité, je viens de changer l'ip locale de la centrale en 192.168.0.100 et je l'ai modifiée dans la règle NAT.
Cela marche toujours en local mais toujours pas avec l'adresse ip publique mise dans l'appli...

Promeneur

 • 

34 Messages

il y a un an

Re,
J'ai fait un ping sur le 192.168.0.100 de mon portable et il répond sans problème