Un bug des liens vers les derniers commentaires sur Le Forum


Bonjour.

J'ai constaté un bug dans plusieurs discussions :
le lien supposé envoyer vers le dernier commentaire
renvoie en fait vers le message initial du sujet.

Serial Watcher.

10 commentaires

Niveau d'utilisateur 7
Badge +9
Bonjour @Serial Watcher,

En effet, il y a un bug avec les liens des derniers commentaires sur certains sujets. On a remonté la situation pour que ce soit résolu au plus vite 🙂

Merci beaucoup pour la remontée !
Bonjour Marie et merci.

Mon titre était simple et juste : "Un bug sur le Forum". Il ne disait pas précisément quelle était la nature du problème, mais pour le savoir, il suffisait de lire mon message. Le titre qui a été mis à la place sans que j'aie été consulté est précis et faux : "Un bug des liens vers les derniers sujets sur Le Forum". Il n'y a pas ce genre de problème. Et n'y a pas non plus exactement de "liens vers les derniers sujets sur Le Forum", il y a un lien vers les Sujets actifs récemment et ce lien n'est l'objet d'aucun bug à ma connaissance.

Le bug dont je parle je l'ai constaté dans deux sujets :
Ce bug ne concerne pas des "derniers sujets" mais bien les derniers commentaires dans ces discussions qui, elles, sont anciennes. Je donne ci-dessous les liens supposés amener aux derniers commentaires dans ces discussions :
Vous pouvez constater que ces liens sont différents mais qu'ils donnent le même résultat.
Niveau d'utilisateur 7
Badge +9
Oups ! En effet, c'est une erreur d'inattention de ma part. Je voulais mettre "commentaire" et pas "sujet". Merci de me l'avoir fait remarquer 🙂

Le titre a été changé pour qu'il soit plus guidant si jamais d'autres membres remarquent le même bug ou se posent la question (ou simplement pour leur signaler qu'il y a un bug avec les derniers commentaires). Si vous désirez un autre titre, n'hésitez pas à me faire une proposition 🙂
Merci Marie.
  • "Un bug des liens vers les derniers commentaires sur Le Forum", c'est bien.
  • "Un bug des liens vers les derniers commentaires des discussions", est-ce mieux ?
Je vous laisse choisir.

On dirait que ce bug atteint les discussions qui ont plus de 25 commentaires
et qui par conséquent s'étalent sur plusieurs pages.

Et ça ne concerne pas que les commentaires tout récents. Prenons Séries incomplètes sur Canalplay. Je donne ici le lien vers le dernier commentaire, celui posté par @Francois il y a 15 jours. Et il y a 15 jours, ce lien fonctionnait. Aujourd'hui c'est toujours le même lien mais le système ne le comprend plus.
Niveau d'utilisateur 7
Badge +12
Il semble que le problème se situe au niveau de la réécriture des pages en html ...

la pagination n'est pas fonctionnelle et pas présente par exemple ce post du sujet cité à la page 3 par @Serial Watcher

Un bon lien correctement composé va directement trouver le bon commentaire:

https://forum.voo.be/mes-chaines-tv-5/series-incompletes-sur-canalplay-4908/index3.html#post103689

donc page 3 et #numéro de post .. "index3.html#post103689"

Par contre si on clique sur lien vers le commentaire en bas sur ce commentaire on obtient un lien erroné qui ne mentionne pas la page et à mon avis c'est incomplet

https://forum.voo.be/mes-chaines-tv-5/series-incompletes-sur-canalplay-4908#post103689

Ce qui d'office renvoie vers le début de la première page car le "#post103689" ne peut être pris en compte car il ne se trouve pas sur la première page qui serait normalement "index.html" mais n'est pas affichée pour simplifier le lien.

L' URL rewriting des adresses PHP du forum par le serveur en HTML est un plus pour le référencement par Google mais quand çà n'est pas correctement mis en place dans un forum, évidemment çà bugge...

J'avais déjà utiilisé le PHPBB SEO donc sur un forum phpBB3 et c'est pas mal du tout mais il faut savoir le mettre en œuvre correctement.
Bonjour.

Je constate aujourd'hui que le bug s'étend aux discussions qui ne font pas plus d'une page.

Cette discussion-ci, par exemple.
Niveau d'utilisateur 7
Badge +12
Et aussi dans les notifications par mail qui renvoient vers le début du sujet et non vers le post en question
Ils font quoi pour réparer ca chez insided ?
Bizarre bizarre. Le bug semble ne plus concerner les discussions sur plusieurs pages mais uniquement les discussions sur une seule page.
Niveau d'utilisateur 7
Badge +12
Oui je vois qu’ils ont apparemment appliqué un correctif pour la pagination exactement comme je l’avais expliqué ! C’est trop fort !
Mais pour la première page il y a une erreur, il manque un séparateur car le paramètre postid n’est pas pris en compte donc revient au premier post .
Niveau d'utilisateur 7
Badge +9
Hello !

En effet, il y a toujours un bug et c'est en cours de résolution 🙂 Merci pour vos remontées et vos différents retours !

Commenter