Adresse ip publique DHCP - Routeur pfsense


Bonjour,

Je viens de changer mon routeur pour un pfsense avec la box voo en bridge.
J'ai assez souvent des déconnexions dû à l'adresse que pfsense reçoit sur son interface WAN, voici les logs:
May 4 13:42:55php-fpm62417/rc.newwanip: pfSense package system has detected an IP change or dynamic WAN reconnection - 85.201. -> 192.168.100.10 - Restarting packages.
May 4 13:42:55check_reload_status Starting packages
May 4 13:42:55php-fpm47189/rc.newwanip: pfSense package system has detected an IP change or dynamic WAN reconnection - 192.168.100.10 -> 85.201. - Restarting packages.

On voit qu'il reçoit une adresse en 192.168.100.10 pendant 1 seconde.
Le souci de cela c'est qu'il redémarre tous ses services et cela engendre une déconnexion.
Comment se fait il qu'il reçoit une IP "privée" sur son interface WAN ?
Je précise que le pfsense est directement connecté au modem voo.

Merci,
Cyhead

9 commentaires

Niveau d'utilisateur 4
Badge +6
Bonjour,

Je viens de changer mon routeur pour un pfsense avec la box voo en bridge.
J'ai assez souvent des déconnexions dû à l'adresse que pfsense reçoit sur son interface WAN, voici les logs:
May 4 13:42:55php-fpm62417/rc.newwanip: pfSense package system has detected an IP change or dynamic WAN reconnection - 85.201. -> 192.168.100.10 - Restarting packages.
May 4 13:42:55check_reload_status Starting packages
May 4 13:42:55php-fpm47189/rc.newwanip: pfSense package system has detected an IP change or dynamic WAN reconnection - 192.168.100.10 -> 85.201. - Restarting packages.

On voit qu'il reçoit une adresse en 192.168.100.10 pendant 1 seconde.
Le souci de cela c'est qu'il redémarre tous ses services et cela engendre une déconnexion.
Comment se fait il qu'il reçoit une IP "privée" sur son interface WAN ?
Je précise que le pfsense est directement connecté au modem voo.

Merci,
Cyhead

Bonjour,

j'ai trouvé ce lien qui pourra peut etre vous aider : Fpsense
Bumblebee Thanks! Your link has helped me too. Great to be a part of this insightful forum.

------------------------------
Zayn
Niveau d'utilisateur 7
Badge +12
@Cyhead
C'est que vous avez certainement des "coupures" de services intermittentes sur votre ligne ...
Votre routeur ne peut voir cette IP (privée) que dans lorsqu' il n'est plus en liaison avec le serveur DHCP de VOO
Vous pouvez peut être reproduire le "phénomène" en débranchant le coaxial du modem et voir si vous avez ce symptôme également.
Il est normal que vous remarquiez une déconnexion vu que c'est apparemment le cas.
Bonjour,
Le souci c'est résolu quand j'ai forcé un redémarrage du modem Voo. Apparemment c'est elle qui me donnait cette IP en 192.168.100.X
Niveau d'utilisateur 7
Badge +12
Oui cela confirme une perte de services momentanée mais bon avec les orages et pannes de courant, cela pourrait venir de là ces derniers jours.
Bonjour,

pour éviter ce problème de réception d'adresse IP de classe C durant une coupure intermittente, il suffit de dire à pfSense de refuser les lease du router Voo en classe C via l'option avancée de l'interface WAN "Reject leases from", il faut ensuite encoder l'ip interne du router voo (exemple: 192.168.0.1,192.168.1.1)



Bien à vous
adresse a refuser, 192.168.100.1 pour être exacte...

pour parfaire l'installation, on peut aussi ajouter une route statique vers l'IP du modem voo en bridge afin de pouvoir contrôler son état, etc (192.168.100.1/32)
De la sorte, même si celui-ci est derrière le pfSense, on peut quand même y accéder depuis le réseau lan géré par le pfSense...

Dernier conseil, désactivez bien l'option "Block private networks and loopback addresses" sur votre interface WAN de pfSense. Sinon quand l'ip changera chez Voo, le renouvellement d'IP ne se fera pas.
Les symptomes du problèmes sont:
  • Status/Interface/Wan => semble bien connecté avec l'IP d'avant
  • Status/Interface/Wan => release/renew à la main nécessaire pour qu'internet reparte
  • Pas d'internet derrière pfSense!
L'explication est relativement simple (même si il m'a fallut du temps pour m'en rendre compte)
Le lease dhcp vient d'une adresse IP de classe A (10....), donc si on coche cette option, on empêche la communication entre le WAN pfSense et le DHCP serveur de Voo (curieusement, je n'ai toujours pas compris pourquoi cela fonctionnait via un release/renew manuel)

Ci dessous l'option a décocher

Commenter

    Gestion des cookies

    Nous utilisons des cookies pour améliorer et personnaliser votre expérience. Si vous acceptez ou continuez de naviguer, vous acceptez règles relatives aux cookies. En savoir plus sur nos cookies

    Accepter les cookies Paramètres de cookies