Résolu

Pas d'accès réseau IPv6 Routeur


Bonjour,

je poste ici car depuis que j'ai mon ordinateur brancher à mon routeur Sitecom X7 ac1200 j'ai plus la connectivité de L'ipv6 donc je voudrais savoir comment puis-je faire des réglage dans mes paramètre du routeur. J'ai fais un p'tit test sur le site test IPv6.




Merci bien.
icon

Meilleure réponse par Boai 9 septembre 2018, 13:24

Non, il n'y a aucun risque de perdre la connectivité si c'est bien configuré, au contraire.

Tout d'abord, vous devez lire la documentation du routeur à fond et vous familiariser avec les différentes parties. Faire un petit dessin avec votre installation va grandement vous aider.

Vous devez dessiner le routeur avec les 'types' de porte qu'il a, il a 2 type de porte (voir schéma dans la DOC). 1 ype LAN (4 portes en général) et 1 type WAN (écran WAN au dessus de la porte en général). Pour faire bref, les 4 portes 'LAN' sont des portes normallement automatiquement 'switchées' (voir google pour ce qu'est un switch, mais basiquement, c'est un appareil qui permet à tout ce qui est connecté sur ces portes de discuter entre eux. Il existe des HUB (mais je ne pense pas que l'on en trouve encore beaucoup, c'est vieux), et des switchs. La grosse différence est que le switch est plus malin que le HUB. Le hub répète sur toutes ces portes ce qu'il a reçu d'une autre porte (donc, par exemple, il reçoit des data sur la porte 1, il envoie d'office sur les 3 autres portes sur un HUB à 4 portes). Un switch est plus malin parce qu'il 'apprend' qui est connecté sur quelle porte et va être capable, si on envoi des données vers une machine 'connue' de n'envoyer que sur la porte où la machine est connue et comme en général, une machine qui démarre envoie plein d'info directement (ne fut-ce que pour demander une adress IP au DHCP), les switch sont très efficace.

Donc, un dessin avec, d'un côté vos machines, au milieu le routeur (s'il fait point d'accès wifi, pas de câble entre les machines et le routeur) et un lien du routeur vers le routeur voo (qui lui, est soit en mode 'bridge', voir les postes dédicacés pour passer le routeur en mode bridge, soit en mode normal).

Sur le dessin vous verrez clairement 4 zones et en fonction de comment vous allez utiliser le router voo, la configuration de votre routeur est différente.

ZOne 1: Internet. Il arrive par le coax et est connecté sur le routeur voo (que celui-ci fasse bridge ou routeur, c'est lui qui reçoit le coax)
ZOne 2: Entre le routeur voo et votre routeur. Ici, cela va dépendre du mode choisi pour le routeur voo. Si BRidge, alors, cette zone doit être considérée comme faisant partie de la zone 1, internet et rien d'autre ne doit être connecté au routeur voo. Le câble entre le routeur voo et votre routeur doit arriver sur le port 'WAN' de votre routeur. Si le routeur voo est en mode FULL (donc, comme livré par défaut), alors, cette zone doit être considérée comme la zone 3, LAN et donc, le câble entre le routeur VOO et votre routeur doit être câblé sur une porte LAN de votre routeur. La porte WAN devient ici inutile (dans certains routeurs ou avec certains soft, mais pas le vôtre, cette porte peut aussi être utilisée en LAN.... )
Zone 3: LAN. C'est la zone où toutes vos machines vont discuter entre elle. Elle doivent être connectées soit sur le WIFI, soit via le cable sur une porte LAN (de nouveau, si en VOO mode Bridge, seules les portes LAN de votre routeurs peuvent être utilisées, si Voo en mode full, celles du routeur Voo et le votre vont faire le même travail, sauf qu'une des portes LAN du routeur voo doit être reliée à une des portes LAN de votre routeur)
ZOne 4: Wifi. Toutes les machines connectées sur le Wifi peuvent discuter entre elles et aller vers internet via le point d'accès wifi. Il faut donc bien vérifier à tout moment sur quel point d'accès la machine est connectée pour savoir, en cas de soucis, où chercher. En général, les routeurs qui ont une fonction Point d'accès indique dans leur interface de configuration les machines connectées sur leur wifi
Pour la partie Wifi. Si vous utiliser le routeur VOO en mode Bridge, il est obligatoire de désactiver le Wifi de voo, vous devez donc configurer d'office le WIFI sur votre routeur. Le plus simple, comme déjà indiqué, est de donner les mêmes nom/mot de passe que ce qui est configuré sur le routeur VOO à l'origine, comme ça, si un jour vous devez repasser le routeur voo en mode full, ce sera transparent pour vos machines. Si vous utiliser le routeur Voo en mode FUll, a vous de voir si vous aller aussi utiliser le Wifi sur votre routeur. Cela n'aurait de sens que si votre routeur est placé dans une zone ou le Wifi voo n'est pas disponible. (Attention, le routeur n'est pas un étendeur de réseau wifi, c'est bien un point d'accès complet qui doit être câblé vers le routeur voo)

Une fois votre dessin réalisé, à vous de voir à quoi va servir votre routeur exactement. En fonction de ça, vous placer les 'zones' comme expliqué et vous devriez voir tout de suite si la zone 2 fait partie de la zone 1 ou de la 3. Si zone 1, vous devez configurer en mode bridge -> port lan chez voo et WAN sur votre routeur et mettre votre routeur avec les configurations 'standard', à savoir: DHCP pour IPV4, auto config pour IPV6 et activer le DHCP de votre routeur. De plus, vous devez donner à votre routeur l'IP 192.168.0.1, subnet 255.255.255.0 (ou /24) et activer le DHCP 'client' ainsi que le Wifi (de nouveau bien lire la DOC, tout ça est clairement indiqué dans la mise en route).
Si zone 3, alors, vous devez câbler les portes LANLAN (surtout pas WAN), donner une IP 192.168.0.50 par exemple (toujours 255.255.255.0 ou /24) et, très très très très important, couper les DHCP et désactiver la configuration de la porte WAN (voir de nouveau la doc de votre routeur, vous devez pouvoir mettre 'aucun' ou un truc du genre).

Normalement, tout ceci est déjà expliqué et documenté dans d'autres post sur le mode Bridge. Vou devriez les relire si les explications ici sont incomplètes ou pas claires.

Au final, si votre dessin est complet et que vous prenez le temps de lire la documentation et de comprendre comment ça marche, c'est assez simple. Il y a beaucoup de 'petits détails', mais ils sont tout de suite très clair grâce au dessin normalement.

Un principe de base pour comprendre. Les machines sont 'stupides' (pas les routeurs, eux, ils font plus de boulot), pour communiquer, elles font ce qu'on leur demande et elle n'ont en général que 2 ou 3 sorties pour discuter et 2 mode de discussion.
1 sortie Wifi
1 sortie câblée

Le principe est simple. Quand vous démarrez une machine, celle-ci chercher à communiquer tout de suite. Si elle est câblée et que le câble est bien banché, de base, en mode automatique, elle va demander un adresse IP. Si, sur le réseau, il y a un serveur DHCP, il va répondre un truc du genre (y a plus, mais c'est pour l'exemple) : "192.168.0.5 / 255.255.255.0 / 192.168.0.1" La partie 1 -> adresse demandée. la partie 2, ce que l'on appelle le masque de réseau, en gros, il doit être identique sur toutes les machines connectées au même routeur, la partie 3, l'adresse de la passerelle par défaut.

Passerelle par défaut -> vers qui je dois envoyer mes infos si je ne sais pas à qui les envoyer... j'explique juste en dessous.

Maintenant que la machine à ces 3 info, elle peut discuter avec n'importe qui. De nouveau: règle très simple (je passe ici le problème du DNS qui est très simple aussi, mais bon ... ce poste est déjà très très long 🙂 ) .

En partant du principe que je connais l'adresse IP de la machine avec qui je peux discuter, il reste 2 possibilité.
Déterminer si l'adresse cible est sur le même sous réseau que moi, cela se voit grâce au masque de sous réseau. Pour faire simple: 192.168.0.1 avec un masque de sous réseau 255.255.255.0 -> toutes les machines avec les adresses 192.168.0.X appartiennent au même réseau, toutes les machines avec une autre adresse, par exemple 192.168.10.1 ou 195.238.2.21 (serveur DNS de Skynet ... bein oui, j'suis un vieux de la vieille et celui-là, je le connais par coeur depuis 20 ans) appartiennent à un 'autre' réseau.
Donc, si l'adresse est sur le même réseau que moi, je vais la joindre directement (remarquez que je ne dis pas 'essayer' parce qu'une machine n'essaye pas, elle le fait. Cela peut ne pas marcher, mais elle "n'essaye pas".)
Si la machine n'est pas sur le même réseau que moi, j'envoie tout à la passerelle par défaut (le troisième morceau des info fournie par le DHCP ci-dessus). Et c'est cette passerelle qui DOIT faire le travail. Cette passerelle est d'office un routeur, c'est le rôle d'un routeur de discuter avec plusieurs réseaux (2, c'est déjà plusieurs 🙂 )


Bon amusement.
Boai.
Afficher l'original

30 commentaires

Niveau d'utilisateur 5
Badge +7
Bonjour,
Normalement, vous pouvez laisser en auto-configuration. Si cela ne marche pas, c'est possible que ce soit lié à un problème avec la manière dont Voo gère l'IPV6 de ses clients et votre routeur (je n'ai pas lu la DOC de votre routeur). Vous pouvez essayer en RD6.. .mais à voir avec la DOC de votre routeur.

Normalement, les fournisseurs d'accès donnent un /56 et pas un /64. Voo se limite à 1 /64 par client. Si votre routeur n'aime pas ça ... c'est possible. A voir.

(notez bien que c'est au niveau LAN qu'il faut chercher, au niveau WAN, un /64, c'est normal), on parle bien de la partie "Prefix Delegation".

Boai.
Bonjour,
Normalement, vous pouvez laisser en auto-configuration. Si cela ne marche pas, c'est possible que ce soit lié à un problème avec la manière dont Voo gère l'IPV6 de ses clients et votre routeur (je n'ai pas lu la DOC de votre routeur). Vous pouvez essayer en RD6.. .mais à voir avec la DOC de votre routeur.

Normalement, les fournisseurs d'accès donnent un /56 et pas un /64. Voo se limite à 1 /64 par client. Si votre routeur n'aime pas ça ... c'est possible. A voir.

(notez bien que c'est au niveau LAN qu'il faut chercher, au niveau WAN, un /64, c'est normal), on parle bien de la partie "Prefix Delegation".

Boai.

Bonjour,
Merci de votre réponse donc j'ai fais ce que vous m'avez dit et ça ne marche toujours pas (en 6RD) et "Prefix Delegation" je sais pas ce que sais.
Où puis-je trouver les nombre qui sont avant /64 ?

Bien à vous
Niveau d'utilisateur 5
Badge +7
HEllo,

Alors, remettez votre routeur en mode "configuration automatique". Je vais essayer de lire la DOC voir si je trouve qqch.

Quelques petites questions supplémentaire. Pourriez-vous vérifier les 'logs' de votre routeur et les panneaux de 'status', vous devriez pouvoir voir si celui-ci reçoit bien l'IPV6 et l'utilise.
  1. Sur votre machine (un windows, je suppose ? ), ouvrir une ligne de commande (cliquer sur le sigle windows10 et directement taper 'cmd' au clavier puis 'enter', une fenêtre noir devrait s'ouvrir.
  2. taper dans la fenêtre ipconfig et copier/coller les valeurs montrée en cachant les données chiffres des 2 dernières parties des adresses) (style, 192.168.0.0 -> 192.168.x.x avec ms paint par exemple via un printscreen). Sinon, chercher sur google (capture d'écran sous windows. Utiliser paint sous windows)
Avec ces infos, on devrait voir un peu mieux ce qui marche ou pas.

Question subsidiaire, utilisez-vous un anti-virus ? si oui, lequel ?

Boai.
D'accord, je suis parti voir les log du routeur et donc je vois start IPv6 Firewall une ligne en dessus stop IPv6 Firewall. Je pense que le pare feu de mon routeur bloque l'accès à l'IPv6 je vais la désactiver pour voir. je n'ai pas d'anti virus j'utilise celui de Windows 10. J'ai modifer avec Photshop pour l'image.


Voilà le Manuel de mon routeur en PDF en Anglais.
Bien à vous.

je viens de tester en enlevant le Pare feu du routeur et j'ai toujours pas accès IPv6 et j'ai aussi Adresse LAN IPv6 : aucun (qui est vide)
il y a quelque chose qui vient de se rajouter dans les logs IPv6, DHCPv6 IP Obtain /64 avec des plein de chiffre dont j'ai enlever pour que on ne voient pas.
j'ai toujours NET, start IPv6 Firewall NET, stop IPv6 Firewall
Niveau d'utilisateur 5
Badge +7
Ali,
Merci. Très instructif.

Il y a manifestement un problème au niveau soit de votre routeur, soit de votre PC. l'adresse de passerelle IPV6 n'est pas correcte. Cela devrait être une adresse 'locale' et pas une adresse publique.

Je vais chercher dans la doc du routeur pour essayer de voir ce qui ne va pas.

Peut-être un détail. Pourriez-vous vérifier les paramètres IPV6 de windows (paramètres de la carte réseau). Les paramètres IPV6 devraient être comme en IPV4, tout en automatique.
Boai.
Ali,
Merci. Très instructif.

Il y a manifestement un problème au niveau soit de votre routeur, soit de votre PC. l'adresse de passerelle IPV6 n'est pas correcte. Cela devrait être une adresse 'locale' et pas une adresse publique.

Je vais chercher dans la doc du routeur pour essayer de voir ce qui ne va pas.

Peut-être un détail. Pourriez-vous vérifier les paramètres IPV6 de windows (paramètres de la carte réseau). Les paramètres IPV6 devraient être comme en IPV4, tout en automatique.
Boai.

D'accord mercii à vous en tout cas 🙂 tout est en Auto. Moi je me demande si c'est pas à cause de mon pare feu Ordinateur ou alors à cause du pare feu du routeur.
Bien à vous
Niveau d'utilisateur 5
Badge +7
A priori, votre routeur n'arrête pas de demander un lease DHCP à VOO, ce sont ces échanges qui sont dans les logs. Bizarre qu'il demande tout le temps. Sans vouloir donner l'IP, est-elle tout le temps identique ? Si non et que queVoo monitore ceci (ce qui devrait être le cas), ils ne devraient pas tarder à vous recontacter ... Si c'est toujours la même adresse, c'est que votre routeur la 'refuse'. PEut-être justement parce que c'est un /64 et pas un /56. Je vais checker la doc de votre routeur.

Boai.
Oui c'est des même N°.

Niveau d'utilisateur 5
Badge +7
Bon ... j'ai vérifié la doc .. pas très parlant tout ça...

Bref. Voir si un expert Voo ou quelqu'un d'autre a déjà testé ce routeur précis (qui semble assez vieux)... Il semble accepter sans problème les /64 ....

Je regarderai encore un peu plus loin demain...

Je ne pense pas que le problème vienne de VOTRE firewall, mais peut-être bien celui sur le routeur, bien que cela semble bizarre. Si vous n'avez pas encore trop modifié la config du routeur, peut-être le réinitialisé et d'abord essayer de faire marcher la connectivité avant de configurer le FW (en DHCP V4 et en auto config pour le V6)?

Boai.
D'accord je vais tester ça. Mercii à vous et puis à demain.

Bonne soirée.
Niveau d'utilisateur 2
Badge +3
Bonjour,

Ali, Est-ce que tu as bien mis en mode brigde ton modem/routeur de VOO et WiFi coupé avant d'aller plus loin?
L'adresse IP LAN qui utilise le 192.168.0.1 ou 192.168.1.1?

Bien à toi,

Jerem'
Bonsoir,

j'ai le fait une fois mais sa à fait un peu n'importe quoi genre j'avais plus de la connexion et il fallait que j’aille réinitialiser. Vous pouvez m'expliquer le Mode bridge ?
L'adresse IP LAN qui utilise le 192.168.0.1 ou 192.168.1.1? comment ça ?
Bien à vous.
Niveau d'utilisateur 2
Badge +3
Bonsoir,

Si tu veux utiliser pleinement ton routeur Sitecom X7 comme IPV6, nattage etc etc...

Première chose, tu dois mettre en mode bridge sur ton Modem de Voo => https://assistance.voo.be/fr/internet/activer-mode-bridge-modem-voo

Et puis une seule connect possible, c'est ton routeur Sitecom qui se branche sur le modem et ça devrait passer avec l'adresse IPV6! ;)

Bien à toi,
Niveau d'utilisateur 7
Badge +12
Hello
@Ali.B
certes si vous masquez des informations non sensibles comme les IP locales dans vos screens, les intervenants ne peuvent pas savoir que vous faisiez du double NAT avec 2 routeurs en cascade..

.@Jereminiah a bien fait de soulever ce point ...

Le modem routeur de voo devrait être mis en bridge ( donc redevient un simple modem ) pour utiliser un routeur personnel et obtenir directement les IP v4 et v6 de VOO.

Une question : quel modem possédez vous de chez voo ?

Le firmware de votre routeur sitecom est il a jour également car il est ancien et bon pour ce qui est de la gestion de l’ipv6 il vaut mieux avoir le firmware le plus récent.

Bonne soirée
Bonsoir, @roylion15 @Jereminiah
Je viens de tester le mode bridge et quand je le met et je desactive le Wi fi j'ai un triangle jaune qui s'affiche à coter mà connexion sur mon pc et donc je suis obliger de reinitialiser. Je possède le modem Netgear. Oui il est à jour mon router en 1.8. Question le router est dans ma chambre sa n'affecte rien ?
Bien à vous.
Niveau d'utilisateur 7
Badge +12
Hello
Verifier que votre routeur est bien configuré en DHCP sur le wan pour la connexion...
Attention aussi qu’en mode bridge, un seul appareil peut être raccordé au modem voo c’est uniquement votre routeur personnel, tous les périphériques, y compris les box tv de voo doivent être connectés sur les ports LAN de votre routeur personnel sitecom.
Voo n’attrIbue qu’une IP publique par client et donc c’est votre routeur qui l’obtiendra.
Bonsoir,

Ah dans ce cas là di c'est un seul périphériques que je peux brancher je peux oublier IPV6. Bon un peu dégoûté mais c'est pas grave.

BBonne soirée.
Niveau d'utilisateur 7
Badge +12
Un seul périphérique en bridge sur le modem voo = >> votre routeur perso et tous vos appareils connectés à votre. routeur perso

Pour ipv6 ça devrait fonctionner mais cela dépend uniquement de la compatibilité de votre routeur personnel avec l’ipv6 native de VOO ...

Je fonctionne en bridge depuis des années et mon routeur asus fonctionne parfaitement en IPv4 et IPv6.

aucun réglage particulier : placé sur « mode natif » , dhcp PD, SLAAC et RA activés (tout est resté par défaut)
Bonjour,
Mais sa veut dire que le câble de votre Tv est brancher au router avec tout vos appareils ? Et votre router se trouve où ? Parce que moi le soucis c'est que si je mais en mode bridge je devrais faire beaucoup de câblage chez moi. Apres si il y a pas d'autre moyen tant pis j'abandonne IPV6 et puis voila.

Bien à vous.
Niveau d'utilisateur 7
Badge +12
moi le routeur asus est relié au modem voo via 50 cm de câble et ensuite cela va vers un switch 16 ports qui alimente les différents appareils proches et aussi ça part en câble r j45 vers les pièces de la maison....

il vous vous sert a quoi ce routeur ?
Ne pouvez vous pas plutôt le passer en mode access point ?
A oui la galère. Enfaite ce router sert à mette du wi fi dans ma chambre et la chambre de mon fils et le câble qui relie le router à mon pc ou j'ai IPV6 qui ne fonctionne pas par contre si j'en mène le pc dans le salon et que je le branche à mon modem j'ai IPv6. Que voulez vous dire par access point ?
Niveau d'utilisateur 7
Badge +12
Certains routeurs permettent de basculer dans le mode "access point" ( AP )
Dans ce mode un peu similaire au mode bridge sur le modem VOO, il ne fait plus routeur mais simple switch et AP et permettra donc de diffuser aussi son réseau wifi ... par contre plus de fonctions de routage ou de nat ...
Tous les routeurs ne le permettent pas mais ce serait une solution qui permettrait certainement de récupérer IPV6 même si ce n'est pas vital ...
Néanmoins ce routeur n'étant pas déjà pas TOP et un peu ancien, je ne suis pas certain qu' il le permette nativement même si certains ont parfois pu bidouiller un mode AP en désactivant le NAT et DHCP et entrer par un port LAN au lieu du WAN sur ces vieux modèles, mais tout cela devient un peu bricolage et je conseillerais plutôt de mettre un routeur plus récent et plus performant ...
Niveau d'utilisateur 5
Badge +7
Hello,
Effectivement, j'ai oublié de poser la première et évidente question => le mode bridge. Cela clarifie beaucoup de chose.

Bref, en résumé.
Soit vous essayez d'utiliser le routeur comme un routeur (et donc, connecté tout seul sur le modem voo (le modem voo sur le port WAN du routeur dans ce cas) et toute la maison est ensuite connectée derrière lui
Soit vous l'utiliser comme switch ou AP (parce qu'au final, un routeur est un switch évolué et un AP inclus dans un routeur peu très bien fonctionner comme un simple AP, sans routage).

Pour l'option 1, comme indiqué par Roylion, en mode automatique pour IPV6 et en mode DHCP pour IPV4 (dans la partie configuration de votre ISP) et ça devrait rouler.. une fois OK, alors, vous pouvez jouer sur les FW (les parce que 1 FW IPV4 et 1 IPV6), En faisant toujours attention de garder une config de backup avant toute modification du FW parce que si certaines erreurs => plus d'accès... et là, seul un reset factory est possible.

Pour l'option 2,c'est tout à fait possible. Il faut:
- Donner une IP au routeur qui n'est PAS l'ip du gateway, mais bien sur le même range que le modem voo (en général, les routeurs n'accepte pas le DHCP pour leur propre adresse) Attention avec les modem Voo, je pense qu'il faut réserver l'adresse dans le range DHCP sur le modem voo pour éviter des conflits.
(il n'est pas nécessaire d'attribuer une IPV6... mais le mieux serait alors de le mettre en auto config, il devrait récupérer son IP du serveur DHCP tout seul... à tester)
- Désactiver toutes les fonctions DHCP (IPV4 et IPV6)
- Désactiver toutes les fonctions NAT et firewall (vu que le routeur va devenir un simple switch, il va être compliqué de comprendre si qqch ne va pas si on lui demande de faire FW en plus)
-Configurer les parties Wifi. Conseil, mettre les mêmes paramètres que pour la partie Voo, ainsi, les appareils prendront automatiquement le réseau le plus puissant de manière transparente (sauf peut-être la première fois, mais après ... tout seul).

Je ne vois pas l'intérêt d'acheter un AP séparé si vous avez ce routeur sous la main. Sauf si vous avez peur de mettre un peu les mains dans le cambouis, mais cela n'a pas l'air de vous faire peur :-)

Boai.

Commenter