Comment configurer le NAT sur mon routeur VOO pour un serveur FTP ?


Bonjour,

J'essaye de configurer le NAT sur mon routeur VOO pour un serveur FTP sur une machine de mon réseau local... le truc super simple... mais ça ne fonctionne pas 😛.

IP publique routeur 213.xxx.xxx.xxx
IP interne routeur 192.168.0.1
IP server FTP 192.168.x.xx

Je met donc la configuration suivante dans Router/NAT :

INTERNE EXTERNE
Adresse IP Port Début Port Fin Adresse IP Port Début Port Fin Protocole Description Activé
192.168.x.xx 21 21 0.0.0.0 21 21 BOTH Oui

J'ai aussi essayé en mettant 213.213.215.230 dons Adresse IP Externe, mais ça ne marche pas non plus...

Déjà je me pose un question existentielle sur la configuration du NAT, pourquoi il me demande une IP Externe ??? Quelqu'un peut m'expliquer à quoi ça sert dans ce cas ? si il y avait plusieurs interfaces externes je comprendrais mais la... :?:D ?

Et deuxième question, si quelqu'un à une idée du pourquoi cela ne fonctionne pas... 🙂.

Grand merci d'avance pour votre aide et bonne soirée à tout le monde ^^,

Klarix

18 commentaires

Bonsoir,

D'abord il vaut mieux effacer votre adresse IP externe de votre message.

Ensuite, est-ce que votre adresse IP est bien publique, comme expliqué ici:
https://forum.voo.be/trucs-et-astuces-internet-21/comment-savoir-si-suis-ip-publique-ou-privee-cgn--5738

Finalement, est-ce que vous utilisez une connexion FTP passive ?
Niveau d'utilisateur 7
Badge +12
Comme c'est le Technicolor il y a un serveur ftp intègré , il est peut être actif et fera conflit sur le port 21 ...
Bonsoir,

D'abord il vaut mieux effacer votre adresse IP externe de votre message.

Ensuite, est-ce que votre adresse IP est bien publique, comme expliqué ici:
https://forum.voo.be/trucs-et-astuces-internet-21/comment-savoir-si-suis-ip-publique-ou-privee-cgn--5738

Finalement, est-ce que vous utilisez une connexion FTP passive ?


Merci d'avoir effacé une partie de mon IP publique, mais je pense que vous avez répondus à votre question vous même... celle-ci commençant par 213, il s'agit pour moi d'une IP publique...

Peu importe pour le FTP passif ou pas, un telnet sur le port 21 devrait au moins afficher un début de réponse, or ici la connexion ne peut pas être établie (corrigez moi si je me trompe :))...

/edit1: un telnet sur mon ip privée du PC ayant le serveur FTP installé fonctionne lui très bien, et m'affiche des infos sur le serveur FTP... ce qui me conforte dans mon idée le routeur ne fait pas le NAT pour une raison ou un autre...

Une explication à ma question existentielle sinon ? Je ne sais toujours pas s'il faut ou non renseigner son IP EXTERNE dans la configuration NAT et s'il faut le faire, alors pourquoi (pure curiosité :)).

En ce qui concerne le serveur FTP intégré, j'ai mes doutes une fois encore à cause du telnet sur le port 21 qui n'aboutit pas... à mon sens cela signifie que le routeur n'écoute pas sur ce port pour une raison ou une autre, non ?

/edit2: je viens de vérifier, le serveur FTP intégré au modem est bien inactif.

Merci en tout cas pour vos réponses, et mes excuses si je raconte n'importe quoi... j'essaye juste de comprendre 🙂.

Bonne soirée à tous,

Klarix.
Pour info j'ai été confronté au même problème.

Le service technique de VOO ne sait pas non plus pourquoi ce champ "IP externe" existe. Au final cela marche si on laisse 0.0.0.0

Par contre il ne faut pas oublier d'appeler VOO pour basculer l'IP externe du router de privée en publique. Ca ne peut pas se faire soi-même dans le router.
Niveau d'utilisateur 7
@klarix : Je viens de vérifier et votre adresse ip est bien publique, on peut donc écarter cette piste 🙂
Du coup, j'ai transmis au service concerné afin qu'un de nos collaborateurs voie ce qu'il est possible de faire !
En attendant, avez-vous testé avec les conseils de bibi357 ?
Niveau d'utilisateur 7
Badge +12
Hello,
Je ne suis pas sur d'avoir saisi si vous parlez de FTP sur votre pc ou bien celui du routeur TC mais TELNET, c'est le port 23 par défaut et non le 21 qui est prévu pour le FTP ... le TC ne répondra pas en TELNET depuis votre LAN de toute façon.
Niveau d'utilisateur 7
Badge +12
Encore des pistes pour le non fonctionnement :
Votre PC ... il est en DHCP avec une réservation dans le routeur ou bien vous l'avez mis en ip fixe directement sur l'interface réseau ?
Le port 21 est-il aussi ouvert dans le pare feu du PC en question ?
Quel programme de serveur FTP avez vous installé ?
Niveau d'utilisateur 5
Badge +7
Dans un soucis d'éviter que le moindre port scan vienne frapper votre FTP, je vous conseille de viser bien plus haut pour le port externe (genre 12548 (pour info, il y a 65534 ports disponibles .. à quelques exceptions près).)

Pour le reste, si tout est bien configuré, seuls les experts voo peuvent vous aider pour vérifier pourquoi cela ne fonctionne pas.

Parfois, il peut être utile de supprimer les configs déjà réalisées et recommencer depuis le début, cela permet parfois de voir ce que l'on a raté.

Ne pas oublié de se connecter en mode 'passif FTP' sinon, cela ne fonctionnera pas correctement 🙂
Bonjour à tous,

Je rencontre un problème similaire. J'ai installé un service sur mon ordinateur qui fonctionne très bien en local, l'étape suivante étant de pouvoir y accéder à distance. Mon IP externe est dynamique, donc j'ai créé un compte sur no-ip.com pour résoudre ce problème et j'ai configuré NAT sur mon routeur pour lier le traffic vers un port de mon routeur à un port spécifique sur mon ordinateur.

Cependant, j'ai beau essayer et essayer, le transfert n'a pas l'air de fonctionner. Le port n'est même pas ouvert sur mon routeur, selon nmap...

Quelqu'un aurait-il une piste ?
Niveau d'utilisateur 5
Badge +7
Bonjour,
Vous devez avant tout vérifier si vous avez une adresse IP derrière le CGNAT de voo ou une adresse publique. Quel sont les 2 premières séries de chiffres (gauche) de votre IP ? Un expert Voo pourrait aussi contrôler et faire le changement nécessaire si besoin.

Boai.
Bonjour,

Tout d'abord, merci pour votre réponse. Je pense que j'ai une IP publique (elle commence par 78). Cependant, je ne suis pas sur que vous m'ayez bien compris. Je cherche à forwarder un port de mon routeur vers mon ordinateur (localement). Je ne m'y connais pas spécialement, donc je ne fais que des suppositions mais si le rôle d'un routeur est de distribuer des paquets, il devrait être possible de configurer un port du routeur (par exemple 192.168.0.1:21) qui forwarderait tous les paquets reçu vers une adresse interne (par exemple 192.168.0.10:21), exact ?

J'ai essayé d'une adresse locale et d'une adresse distante, aucune des deux tentatives n'ont fonctionné (logique...):
- soit le forward ne se fait pas et mes paquets arrivent dans le vide (mais alors le rapport nmap devrait me dire que le port est ouvert),
- soit le firewall droppe mes paquets. Si tel est le cas, je ne vois pas exactement dans ma configuration ou ça coince...

Merci beaucoup
Niveau d'utilisateur 7
Badge +12
Cette configuration ne marchera pas vous redirigez uniquement en interne ce qui ne sert à rien pour un accès extérieur ... vous avez le Technicolor ou un autre routeur ?
J'ai réussi, ça fonctionne. Savez vous si il est possible de configurer le firewall pour n'autoriser qu'une seule adresse mac pour ce port en particulier ?

Un grand merci
Niveau d'utilisateur 7
Badge +12
Hello
On ne sait toujours pas quel routeur VOO ou autre vous possédez ....
Malgré çà je ne crois pas que ce soit possible de n'autoriser qu'une seule adresse mac pour un accès distant sur les différents routeurs de VOO... Je peux me tromper mais je ne me souviens pas avoir vu cela sur le dernier modèle en date, le technicolor et sur le plus ancien Netgear là c'est impossible au vu des réglages accessibles à l'utilisateur. Mon technicolor étant en bridge avec un autre routeur, je ne sais pas tester çà.
Ce genre de réglages particuliers nécessite souvent un routeur plus évolué du commerce qui permet des fonctionnalités avancées.
Mon routeur est un technicolor un peu pourri. Malgré ça, les options du firewall me semblent quand même avancées, ce qui semble un minimum de nos jours...
Que vous apporte le mode Bridge ? Je demande cela parce que j'ai un ancien routeur que j'aimerais bien utiliser pour fournir une connection fixe à mon ordinateur. Avez vous des pertes de vitesse?
Niveau d'utilisateur 7
Badge +12
Pourquoi dites vous que votre TC est un peu pourri ?
Moi ce modem routeur ne me convient pas car il n'a pas les fonctions de VPN, pas de timers pour couper le wifi la nuit et pas de fonctions avancées pour les réglages de mon réseau ( serveur / clients en domaine local ) et encore d'autres choses, également il y a des bugs et moi j'ai autre chose à faire que me prendre la tête avec les routeurs "bridés" des opérateurs ...
Le mode bridge permet de désactiver toute la partie routeur du TC et utiliser un routeur du commerce de meilleure qualité et plus performant avec des fonctionnalités pour l'utilisateur avancé... Le TC devient alors un simple modem câble qui sert d'interface entre le coaxial et le RJ45... (les wifis doivent être également désactivés) et seul appareil pourra être alors connecté, c'est votre routeur perso qui fera son travail de routage et fournira aussi les wifis ... Non, je n'ai pas de pertes de vitesses, et au contraire ma connexion est rapide (204 / 11) et parfaitement stable H24 et le wifi très performant ...
Attention quand vous dites "je voudrais essayer un ancien routeur" ... lequel ? parce que s'il est trop ancien il va brider votre connexion et vous n'obtiendrez sans doute plus votre vitesse maxi ... Avec les vitesses fournies par VOO, il vous faut du bon matériel et récent si possible.
Je dis qu'il est un peu pourri parce qu'il est bridé et que les options sont assez limitées. De même, l'ancien routeur que je voulais configurer est bridé également, c'est une bbox de proximus. Par ailleurs, je pense qu'il n'est même pas possible de le configurer en bridge. L'idéal serait de pouvoir se connecter au routeur en mode admin évidemment, mais c'est une autre histoire...

Merci beaucoup pour ces informations, je vais envisager d'acheter un routeur de meilleure qualité du coup
Niveau d'utilisateur 7
Badge +12
Une BBox de proximus ne peut convenir car c'est un modem routeur adsl /vdsl et il n'est pas possible de connecter cela sur le câble ou même derrière le modem VOO Technicolor placé en bridge , il vous faut un "simple" routeur ...

Commenter