Passer au contenu principal
fabsfan

Éclairé

 • 

141 Messages

jeu. 17 sept. 2015 07:14

Voomotion et Linux

Impossible de faire tourner voomotion sur linux. Le flash n'est plus mis à jour sauf sur Chrome mais là image noir. Des solutions?
Voo ne penserait il pas à adapter voomotion en HTML5 et abandonner le Flash qui tente à disparaître.

Réponses

Solution acceptée

Promeneur

 • 

1 Message

il y a 5 ans

Bonjour à tous,

J'aimerais apporter quelques précisions par rapport à la réponse de Fanny. En effet, VOOmotion n'est pas supporté "nativement" sur les distributions Linux, mais il est tout à fait possible de le faire fonctionner moyennant quelques manipulations : le plugin Pipelight fait tourner une version Windows de Flash qui lui permet de gérer des contenus vidéo protégés. Pour l'installation, voir: https://doc.ubuntu-fr.org/pipelight

Le résultat en images :

On est bien d'accord, ce n'est pas une solution tout à fait "propre" si on adhère fermement à la philosophie du libre, mais bon...
Fanny

Apprenti

 • 

999 Messages

il y a 5 ans

Bonjour fabsfan,

J'ai bien lu votre message.

Avez-vous utilisé un autre navigateur sur Linux ?
Quelle(s) chaîne(s) souhaitiez-vous regarder ?
Lors de votre connexion à VOOmotion, était-ce à votre domicile ?

Bonne fin de journée,

Fanny

Ancien Officiel VOO

fabsfan

Éclairé

 • 

141 Messages

il y a 5 ans

Oui utilisé avec plusieurs navigateur et vu qu'ils refusent tous la mise à jour flash (pour protection), voomotion ne fonctionne plus. Oui au domicile et toutes les chaines bien sur
Mustafa

Apprenti

 • 

633 Messages

il y a 5 ans

Essaye peut-être via cette adresse

https://ios.voomotion.be

La version iOS utilise je pense le HTML5 donc peut-être compatible avec linux?
Le capitalisme, c'est l'exploitation de l'homme par l'homme ! Le syndicalisme, c'est le contraire. Coluche
Fanny

Apprenti

 • 

999 Messages

il y a 5 ans

Avez-vous essayé le liens de Mustafa ?

Rendez-vous sur cet article : Quelles sont les conditions minimales à respecter pour utiliser VOOmotion sur mon ordinateur ?

Ancien Officiel VOO

Promeneur

 • 

45 Messages

il y a 5 ans

Bonjour à tous.

Tournant moi-même sous une distribution GNU/Linux (ArchLinux). Comme tous les utilisateurs tournant sur cette plateforme, je suis impacté par ce problème.

Utilisant Chromium, j'ai tout d'abord pensé à une détection sur l'User-Agent. Je l'ai donc changé de façon à me faire passer pour un Windows 7 x64 sous Chrome. Même problème, écran noir sur les chaînes.
Comme Chromium utilise la version PPAPI du plugin Flash v18, j'ai tout d'abord pensé à un problème cette API.
Je suis donc passé sur Firefox, mais j'utilise sur ce navigateur un wrapper me permettant d'utiliser la version de Flash v18 PPAPI de Chrom(e|ium) sous Firefox. J'ai donc enlevé mon wrapper pour utiliser l'ancienne version de flash utilisant NPAPI (11.2).
Ok en procédant de la sorte j'obtiens le message d'erreur à l'emplacement de la vidéo "To view this page ensure that Adobe Flash Player version 16.0.0 or greater is installed." (cf screenshot 2)

Comme demandé, je me suis fait passer pour la version iOS, mais l'interface est inutilisable (cf. screenshot 1).

Aussi, j'ai regardé les logs de ma console et j'ai vu que le fichier XML http://fpdownload.adobe.com/crossdomain.xml refuse d'être chargé, car il est introuvable (404) (cf. screenshot 3)
Fanny

Apprenti

 • 

999 Messages

il y a 5 ans

Bonjour,

Après vérification, VOOmotion n'est pas supporté par le système d'exploitation Linux.

Fanny

Ancien Officiel VOO

Promeneur

 • 

45 Messages

il y a 5 ans

Bonjour,

Après vérification, VOOmotion n'est pas supporté par le système d'exploitation Linux.

Fanny


Bonjour. Pouvez-vous donner les informations techniques qui pourraient expliquer ce non fonctionnement? La communauté pourrait dans pareil cas peut-être trouver un moyen détourné pour le faire fonctionner.

En vous remerciant d'avance.

Promeneur

 • 

45 Messages

il y a 5 ans

Quelle est la version de votre Mac OS ?
Quelle est la version de votre navigateur ? Essayez sur Google Chrome.

Fanny

Elle n'est pas sous OS X (ça ne concerne pas un Mac ici), mais sur iOS (iPad Air2).



Personnellement, ne disposant pas de périphérique iOS, je ne sais pas dire ce qu'on devrait obtenir (mais je peux demander à un voisin), mais à l'issue de l'indicatif de chargement (le cercle qui tourne), j'ai ceci qui s'affiche et puis plus rien (premier screenshot, en me faisant passer pour iOS en changeant mon user agent, j'obtiens une interface comme visible au second screenshot).
fabsfan

Éclairé

 • 

141 Messages

il y a 5 ans

Le problème est le même sur linux que pour ios, pas de gestion du Flash donc pas de voomotion. Même sur ios.voomotion.be qui ne fct que sur IOS. Pour info au programmeur de l'appli Flash est en passe de disparaître même sous Windows et surtout dans la version 10, il faudra donc modifier vos applis ;)

Promeneur

 • 

45 Messages

il y a 5 ans

Perso, j'ai aucun problème avec Flash sous Linux, juste avec Voomotion. Et Flash est toujours supporté sous cet OS, comme précisé plus haut, on a même deux solutions sous Linux actuellement:

- Adobe Flash 11.2 (bloqué à cette version) en NPAPI supporté jusque Mars 2017.
- Adobe Flash 16 en PPAPI (en extrayant le plugin de Google Chrome).

Je pense que VOO n'a pas utilisé une solution HTML 5, car pour une raison de droits, ça nécessiterait les Media Source Extensions (MSE) qui sont actuellement pas supportés partout et toujours en draft par le W3C.
La solution la plus simple était d'utiliser RTMP et donc Adobe Media Server nécessitant Flash.

Src: https://developer.mozilla.org/en-US/Apps/Build/Audio_and_video_delivery/Live_streaming_web_audio_and_video

1 Message

il y a 4 ans

Bonjour,
Il y a une autre solution vérifiée sur Ubuntu 16.04.1
1) installer Wine qui fait partie des paquets officiels
2) télécharger et enregistrer
a)Firefox pour Windows
b) Flash Player 24 pour Windows
3) installer à l'aide de wine (il suffit de sélectionner le fichier et ensuite avec la touche de droite ouvrir avec Wine)
a) Firefox ( un icône de Firefox apparaît sur votre bureau)
b) Flash Player
4) éventuellement redémarrer le PC
5) démarrer Firefox via l'icône sur le bureau, ensuite se connecter à Voomotion et voilà le tour set joué

Promeneur

 • 

31 Messages

il y a 4 ans

Le problème vient, une fois de plus de cette insanité de DRM qui ne joue qu'avec Apple et Mickey$oft exclusivement, toute autre platforme est bannie de la course pour une question de gros sous tombant dans leurs popoches, ce qui est absolument INACCEPTABLE !!!
La communauté Linux doit se mobiliser pour contrecarer ces plans, il y a eu exactement le même problème avec Netflix, mais eux, ont eu l'intelligence de rendre leur système compatible sous Linux à condition d'utiliser Chrome qui est compatible DRM/HTML5...
Quand Voo vont-ils ENFIN de ce décider à adopter la même résolution permettant aux utilisateurs de platformes OpenSource de profiter de leus services, ces derniers ayant comme les autres payé leur abonnement chez Voo et étant tout à fait dans leur bon droit de prétendre à pouvoir utiliser VooMotion !!!
Merci Voo de vous remuer un peu en ce sens !!!
fredOfred

Citoyen d'honneur

 • 

598 Messages

il y a 4 ans

Juste une précision, la solution n'est plus d'actualité, et ne fonctionnera pas car Pipelight n'est plus maintenu. Il est obsolète, et sans MAJ de sécurités. Pour répondre à TuxBe, le plus fou, j'aimerai aller voir dans les "caves" de VOO, qu'il y aurait du Linux ne m'étonnerai pas. :8
ABSENT !!!! Inutile d'envoyer un message, je ne répondrai pas. Merci. Alleï, dis, une fois !

Promeneur

 • 

45 Messages

il y a 4 ans

Bonjour à tous,

J'aimerais apporter quelques précisions par rapport à la réponse de Fanny. En effet, VOOmotion n'est pas supporté "nativement" sur les distributions Linux, mais il est tout à fait possible de le faire fonctionner moyennant quelques manipulations : le plugin Pipelight fait tourner une version Windows de Flash qui lui permet de gérer des contenus vidéo protégés. Pour l'installation, voir: https://doc.ubuntu-fr.org/pipelight

Le résultat en images :

On est bien d'accord, ce n'est pas une solution tout à fait "propre" si on adhère fermement à la philosophie du libre, mais bon...


Deux précisions par rapport à cette réponse.

* Contrairement à ce qu'indique le wiki d'Ubuntu, Pipelight est toujours en cours de développement et maintenu (cf. les récents commits sur Launchpad).
* Pipelight ne fonctionne qu'avec les navigateurs disposant de l'API NPAPI, donc uniquement Firefox et dérivés.

Il n'existe à l'heure actuelle toujours aucune solution pour Chrome/Chromium et dérivés (ex.: Opera), car le plugin Flash en version PPAPI ne supporte pas les DRM (testé). Utiliser le plugin Widevine (fourni par défaut sous Google Chrome, mais à installer manuellement sous Chromium) ne résout pas non plus le problème (testé), car ce plugin ne concerne que les EME (Encrypted Media Extensions) d'HTML5 et non les DRM de Flash.

J'ai essayé de déchiffrer manuellement le flux, en rejouant les Cookies, mais on dirait que ffmpeg n'arrive pas à recevoir la clé DRM pour exploiter le contenu du fichier HLS M3U8.